Anyone tried Laird RM1XX modules?

Yes it’s not clear but you can’t just change from Central to Peripheral roles via the UART upgrade because Peripheral uses a different Softdevice (a reserved block of code proprietary to Nordic that implements the BLE protocol).

To change roles you have to use flash over Segger J-Link. Follow the instructions at

Also remember to AT&F* after flashing because the settings format are different. It’ll be confused if you don’t.

I’ve already done that on my test module and it’s working well. I’ve enabled the virtual serial port ( AT+CFG 100 0x0001 ) and can now connect to interactive mode console for configuration with my phone.

This opens a lot of new possibilities!

I can imagine Laird will sell modules pre-configured as Peripherals in the future so you’ll be able to skip the J-Link step.

1 Like

cool ! :sunglasses:

I don’t own a segger j-link device, I see prices from 8 to 300,-, can you advise one, can I use a china clone for this ? or do i need to buy the original edu version …

In theory, the following should work

• J-Link PRO
• J-Link ULTRA+
• J-Link PLUS
• J-Link BASE
• J-Link EDU
• J-Link for Cortex-M
• Flasher PRO
• Flasher ARM
• Flasher Portable

But I will be honest and say I have not testied them personally.

1 Like

I can confirm this. The Central and peripheral role devices make use of different soft devices from Nordic that cannot be upgraded over the UART. It’s also worth noting that you can have peripheral (S110 soft device) or central (S120) soft device but not both together.

Booting into VSP via GPIO has two modes, bridge and command. In bridge mode, the radio is bridged to the UART transparently in a serial cable replacement kind of way. VSP command mode is very useful for configuring the APPEUI and APP key wirelessly. If you use the iOS LairdToolkit, you can use the VSP batch app, to configure the keys from a text file and thus avoiding finger trouble entering keys.


It’s worth mentioning that you can load smartbasic programs over the air and issue certain file management commands over the air. But you can’t update the Laird firmware (Nordic soft device+ smartbasic engine).

The RM1xx uses an Nordic nRF51, which has its memory split in two. The first block contains the Nordic soft device and the second block the application. Within that application space, Laird puts the smartbasic engine and creates a filesystem for storage of smartbasic programs, along with some NV storage.

Mark Duncombe
Laird European Field Application Engineer



I am trying to connect my RM186 to TTN, but when I try to do “XCompile + Load” on “”, I get the error message below. Has anyone encountered the same error and found a fix?
I am wondering whether it could come from an “RM1xx-defs.h” not matching the firmware version (, but I don’t know where I could find the correct one.

The error message:

Failed to compile -9; Application failed to compile
			rc = LORAMACSetDebug(i[0],i[1],i[2])

Compile Error: (0x0433) TOK_UNEXPECTED_TOKEN_IN_EXPR

File   :
Line   : 512
Source : 			rc = LORAMACSetDebug(i[0],i[1],i[2])
       : --------^


actually you didn’t compile but

start updating everything

Good point about the
Do you mean I should upgrade my firmware?
I can’t find the tool to do so - it doesn’t show up on Laird’s website.

no, not really a must - is fine
if you encounter an error during compilation, you can look up the error code.
error codes you can upgrade within the UwTerminal.

could you compile and run ‘hello world’ from the same page ?

Yes “” works fine.
I also tried “”, which compiled correctly but did not execute correctly(“Failed to open I2C, error code: 00005227”) - could not find a match for that error code.

that is by design :sunglasses: I have the same error response, don’t know @ this moment.
for i2c I normally use >

Thanks for your i2c scanner, it works here as well!
BTW what is the firmware version of your RM186?

Where did you get “RM1xxUartFwUpgrade.exe” to upgrade it?
I can’t seem to find it on Laird’s website - no “software download” on any of the products, and no login area either…

I described the update process here: Anyone tried Laird RM1XX modules?
you will find that file in the zip file

Indeed your guide is very clear and helpful.
The only issue is that I can’t find that zip file on Laird’s website. If you have a link to the page where you downloaded it, I am very interested!

I cannot find the firmware to … even after I logged into my user account.

  • they moved the software downloads to the support desk :confounded:

Well at least you found the login page - I haven’t even managed to go that far…

I happen to have the page with download section open, as you are required to login before you can download I do not mind sharing a few links:
RM191 Firmware (BLE Peripheral) -
RM186 Firmware (BLE Peripheral) -
RM191 Firmware (BLE Central) - v17.4.1.0RM186 Firmware (BLE Central) - v18.4.1.0
Release Notes - RM1xx Firmware v17.4.1.0 and
Release Notes - RM1xx Peripheral v18_17_1_0 and v17_17_1_0.pdf
DVK-RM1xx Schematic-V1.pdf
3D Models - RM1xx

You will be redirected to a page stating access is denied, that page provides the option to login (“CLICK HERE”)

1 Like