Anyone tried Laird RM1XX modules?


#206

today its exactly 1 month ago that I ordered 2 RM186 from FARNEL - HOLLAND !
(I cancelled today)

according to their site they have them in stock (not true) and they give as reason that they
need export license documents from LAIRD

today they claimed that 'it's not possible to contact LAIRD about these documents.

I sended an email to Claudio Camilucci a few weeks ago, local sales contact for Laird Embedded Wireless EU, but never got an answer.

So LAIRD / FARNEL.. what's going on ????

disclaimer: I don't have a problem at the moment developping because **** helped me with a few chips so i could continue


(Jose Marcelino) #207

I don't understand. just ordered a couple RM186 modules and 2 dev kits from Farnell the other day with no problem.

Was UK stock, next day delivery for me. I usually prefer Mouser because the price is lower but Mouser free shipping takes about 3 days and I needed these ASAP.

Can it be because I'm buying through a company and you're maybe private?


#209

I've ordered a couple of evaluation kits and modules this week through Mouser. They arrived within 3 working days. (UK here too).
Haven't had a chance to play with them yet. Looking forward to the weekend :slight_smile:


#210

early ' Sinterklaas' present arrived yesterday , the new CH2I RM186/191 adapterboards :sunglasses:


(Gonzalo Casas) #211

Fantastic! @Charles: is there a pcbs.io link available?


#212

you can order them here

I'll test this adapterboard today


(Gonzalo Casas) #213

Looking forward for the results! Also, if you have the time, creating a super mini LAB Story on the website on how to hook up the Laird and getting started with the basics would help a lot of people.


#214

100 % :sunglasses:


under construction


(Gonzalo Casas) #215

So what do you have there? Laird + is that a Pololu step up/down (S7V8A?) + FTDI?


#216
  • Pololu 3.3V Step-Up/Step-Down Voltage Regulator S7V8F3
  • FTDI Basic Breakout USB-TTL 6 PIN 3.3/5V

#217

@BoRRoZ

Very nice pictures, thanks for them :wink:

And boards are working fine ?

just received these $2 FTDI, awesome


#218

Hi Charles, yes the boards are perfect.
Goldplated and easy to solder (even with my eyes :wink:)

now if somebody can make a part for fritzing from your adapterplate ...


#219

I've ordered a RM186 on Farnell yesterday and received it today already, and with free shipping! :grin:
Not sure why some people have so much delay with Mouser..

Now need to solder it as a newbie on soldering, big challenge ahead.. :joy: (thanks for sharing the board @BoRRoZ @Charles)


#220

the delay was with Farnell.. not Mouser.
but maybe they have 'solved' their problems with export licenses.. maybe they really have stock now, who knows, good to know and nice that more people start playing with this incredible underrated module.

  • credits for the adapter PCB go to Charles - CH2I

#221

Yes, indeed :slight_smile:

Now waiting for pcbs.io to ship, says 'Awaiting Panelization' since 5 days now, hope they will ship soon.


#222

as a 'newbie' on soldering.. be very very carefull.. its not that easy :wink:


#223

I'm thinking of ordering some test boards to get some experience with this kind of precise soldering.
Do you have any advice for me?

Worst case scenario I break a €20 board, so will see what happens :wink:


#224

very good idea ! :wink:


#225

Lol :smile:
Yes I know from China is slow but also incredibly cheap!


#227

updating firmware LAIRD RM186 :

connect your RM186 adapterboard with usb serial ( I used this one but others will do )

serial/adapter
Tx Rx
Rx Tx
RTS CTS
DTR RTS
3V3 BLE/LORA
GND 1/8/11/14/21/24

after soldering and wiring check with the terminal program if you can communicate with the module and check the current firmware.
attention switch the usb serial converter to 3V3 logic and make sure that the Vcc of the module is 3v3 !
so don't feed it direct from your PC

now check communication from within the terminal program:

AT I 3

the module answers with the firmware version, here 18.4.0.26

create an account (free) at the LAIRD site where you can check for the latest firmware, download the zip file.

inside you'll find RM1xxUartFwUpgrade.exe the tool to upload the new firmware, which is alsoo included.
at this moment 18.4.1.0

now start this tool.. and point to the new firmware image




finally start your terminal again

and you're up to date