AWS IoT TTN Integration tutorial broken again

It seems like this comes up every time AWS changes their Solution Stack name. All of the answers seem to provide the “current” new Solution Stack name, but no details on what link or doc exactly they used to find the new info.

I tried the results from the June '19 resolution:

and downloaded/modified the cloudformation.template file accordingly, but apparently, it’s updated again since then and still won’t resolve.

I found this site:
https://docs.aws.amazon.com/elasticbeanstalk/latest/platforms/platforms-supported.html#platforms-supported.go

and tried supplementing 64bit Amazon Linux 2 v3.1.2 running Go 1 but I still get the same error…

No Solution Stack named ‘64bit Amazon Linux 2 v3.1.2 running Go 1’ found. (Service: AWSElasticBeanstalk; Status Code: 400; Error Code: InvalidParameterValue; Request ID: b77846ab-9961-48f4-a231-f8f41d26c9be; Proxy: null)

This was apparently the correct solution
https://forums.aws.amazon.com/message.jspa?messageID=957537

The version listed in the “supported” document was incorrect and I had to revert to one version previous.
64bit Amazon Linux 2 v3.1.1 running Go 1

1 Like