AWS IoT TTN Integration Tutorial "broken"?

Seems that the AWS IoT Integration Tutorial is broken. I’ve tried it with a brand new account (as suggested in Solved: AWS IoT Integration) and using one of the default provided regions in the example Quick Start. It fails with “No Solution Stack named ‘64bit Amazon Linux 2018.03 v2.11.1 running Go 1.12.4’ found” so I suspect the template needs updating ? Looking through AWS forums there are quite a few examples of the “Beanstalk Team” updating new platform versions.

I am getting the same errors, would be very grateful is someone can aid with this issue.

48%20PM

The TTN cloudformation template contains: SolutionStackName: “64bit Amazon Linux 2018.03 v2.10.0 running Go 1.11.5”

The current supported version is: 64bit Amazon Linux 2018.03 v2.11.3 running Go 1.12.6

Seems like the cloudformation template should be changed.

Hi, seems that AWS docs about EB must be updated, I found this config template “64bit Amazon Linux 2018.03 v2.11.4 running Go 1.12.6”.

And it worked for me guys.

Hi, I am getting this error too when trying to integrate with AWS IoT. I checked all the instances running and the one in TTN’s configuration template isn’t one of them as a newer version is now being run of Amazon Linux and Go. here is a screenshot.
Screenshot 2020-01-30 16.13.19

What I did was download the CF Template locally and changed the parameters to match the supported Go version on AWS, check the following to get the version:

https://docs.aws.amazon.com/elasticbeanstalk/latest/platforms/platforms-supported.html#platforms-supported.go

Then edit the line : SolutionStackName: 64bit Amazon Linux 2018.03 v2.14.1 running Go 1.13.2
on the JSON CF Template file.

On AWS for Elastic Beanstalk , create a new stack with the upload from file option and upload the edited file.

Hi,

Thanks I have tried you method but it fails, I have also created a new AWS account and it still fails.

image
image

I see the S3 buckets gets created every time.

image

Have anyone found another work around?