Big LoRa32u4 boards topic

I remember LoRa32U4 using around 50mA on active state, that might be too little indeed.
I did obtained the best sleep consumption (200µA) powering the board directly with the 3.3v pin.
For that purpose, I used a simple but nice external 3.3v LDO (HT7333)… and a 10µF capacitor.

H, I did a mistake. BSFrance is out of stock since some time, so I bought a similar board from Amazon, without paying sufficient attention to the description. And so, tomorrow I will have a 915MHz board instead of a 868 version :frowning: .
Do someone have experience in using a Lora32U4 board marked for one band with LMIC set to the other band? I suppose it can work, possibly sub-standard. Thanks.

The solution was under my eyes, but somewhat hidden: on the B side of the board there are pads to be soldered for 500mAh charger.
My board is on a breadboard so I didn’t see directly the pads, but yesterday I received another one so I discovered this nice thing (if only I had looked more at the pictures on top of this thread… :slight_smile: )

… and this is a self-answer: measured in the same conditions, rssi shows barely no difference.

1 Like

Good to know, I would have said around 10dB loss.
On some boards, it’s just a settings difference.

1 Like

While I was looking around for info, I found that modules used by Dragino differ for 3 inductors (and they declare very few difference in performance). Both boards are even not marked, like the one in the picture on top, v1.2.

Hi to everyone , i’ve started working on the LoRa32u4 II v 1.2 i was able to compile correctly the example code in the library https://github.com/matthijskooijman/arduino-lmic, as suggested i started with the ttn-abp example and in the serial i have this:

3881848: engineUpdate, opmode=0x908
3882852: TXMODE, freq=868300000, len=26, SF=7, BW=125, CR=4/5, IH=0
Packet queued
3949188: RXMODE_SINGLE, freq=868300000, SF=7, BW=125, CR=4/5, IH=0
4011976: RXMODE_SINGLE, freq=869525000, SF=9, BW=125, CR=4/5, IH=0
4013040: EV_TXCOMPLETE (includes waiting for RX windows)
4013174: engineUpdate, opmode=0x900

As you can see the serial outout do not start from: Starting…, and so on, one question came in my mind, if i am too far from a gateway the board will output like that ? will it join anyway ? Please help me i have so little experience i do not know how to go on

Thanks a Lot

1 Like

It does not start with “Starting” because in principle you have to wait the Serial is ready, but it does no matter, is just a string. Add this after the begin method invocation to be (almost) sure the Serial is ready while being able to run it also when not connected:

while (!Serial && millis() < 10000);

Regarding the other question, maybe is better to learn something more about LoRaWAN: nodes always transmit without knowing the result. So you will see this output even closed inside a Faraday cage on the other side of the moon. And if you do not have a gateway at reach, you will not join the network, of course (although joining is in principle a correct term only for OTAA).

Now things start to make sense, thank you for the link provided and this is why with the OTAA example it fail to join, with a more complete search it comes out that i do not have any LoRa wan node near enought to try ! Ok than, at least i know that the software is working ! Thanks a lot for the fast and Super clear answer

I’m sorry, off-topic but couldn’t resist: Have you ever thought about upgrading to x64? :wink:

1 Like

XD XD XD No, not really 32bit in enought to do what i need. Anyways still not able to send a packet to the things network yesterday i visited an area near my town where on the ttn map a gateway is marked my code use abp, so i do not know if this could be a problem, another question, in the example code of the library the appkey,the Application EUI and the Device EUI should be lsb or msb ?

well… I understand his nick :wink:

1 Like

Using ABP should not be a problem. OTAA is preferred for several reasons but ABP is simpler and therefore my preferred activation type for doing initial tests. When ABP is working you can try OTAA next. When both ABP and OTAA have been tested successful you can assume that node is working properly. Successful means that on the TTN Console you see traffic arriving in your application.

Tip for testing ABP and OTAA: in TTN Console you can create two different devices (e.g. mydevice-abp and mydevice) for the same node and use one for ABP tests and the other for OTAA. That way you do not have to change/redefine the activation type and keys for the device in the TTN Console when you want to switch activation type and only uploading the corresponding firmware to your node will suffice.

When using the Arduino LMIC library examples use the following formats for your keys/ID’s:

For activation type OTAA use:

// DevEUI (end-device identifier) in little endian / least-significant-byte first format.
static const u1_t PROGMEM DEVEUI[8] = { 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00 };

// AppEUI (application identifier) in little-endian / least-significant-byte first format.
// (For TTN issued EUIs the last bytes should be 0xD5, 0xB3, 0x70)
static const u1_t PROGMEM APPEUI[8] = { 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00 };

// AppKey (application key) in big endian / most-significant-byte first format.
static const u1_t PROGMEM APPKEY[16] = { 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00 };

For activation type ABP use:

// DevAddr (end-device address).
static const u4_t DEVADDR = 0x00000000 ;

// NwkSKey (network session key) in big endian / most-significant-byte first format.
static const PROGMEM u1_t NWKSKEY[16] = { 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00 };

// AppSKey (application session key) in big endian / most-significant-byte first format.
static const u1_t PROGMEM APPSKEY[16] = { 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00 };
1 Like

Just to be sure i’m doig everything right,please can anyone share a working sketch for the LoRa32u4 II v1.2, i have di DIO1 connected to pin 6 of the board. It is ok both ABP or OTAA just a sure working sketch.
Thanks a Lot

From the output you posted it seems ok, so since you do not know yet if there is a gateway available (how far it was the one you saw on the map? which antenna are you using?), I would not do much more on the software. Check the gateway coverage on ttnmapper.

IT WORKS !! Problem was … the antenna, i used the one that came with the module and is not so great, i had to reach the town where the gateway was supposed to be and after that it worked perfectly, so considering this maybe is time to set up a ttn gateway by myself, by doing that coverage will extended even for other people, thanks a lot for the help. Want to try now the otaa activation, I will keep you updated.

Greetings

If the default antenna is very short, likely a 82mm wire will be better and with no cost.

Hi, I just recieved LoRa32u4 II version 1.3. This is unclear to me if I need to solder some pins on board in order to make it running. So far in Windows - if in bootloader more (red LED stable, blue LED flashing) is gets reachable on port 4 only few seconds - so I am unable to upload any sketch. Thanks

Hi Fany, I suggest you to first have a look at the starting talks in this topic, nearly one year ago.
So far, I’m using Lora Feather 32U4 (Adafruit) board in Arduino IDE manager board.
You can also read their tutorial.

Good luck!

Sometimes you have to press the button during compilation, to have the port ready precisely at the time needed.