Can I avoid data being shown in other gateways' Traffic in TTN Console?

Hello all!
Well, I am developing an application sending few messages each hour. The thing is that I can see all messages in the Application Data console but not in the GW traffic. Those messages that I can’t see seem to be received by other gateway (not mine). In metadata I can’t see my GW.
The node is not so far from my GW to not to receive the message, so it can’t be the problem.
So, is there a way that these messages are not reached by the other gateway and just received by mine?
I know that the other gateway will still receive the messages, but I mean, if it is just me who can see them in TTN.

No, you cannot avoid that. It’s radio after all, anyone can receive that. However, the gateway’s Traffic page only shows the encrypted application payload. Only you (the owner of the application) can see the decrypted payload, in the application’s or device’s Data page.

Also, the fact that other gateways receive the transmission has no effect on your own gateway (also) receiving it. So, something is wrong with (the setup of) your gateway, or maybe the device is too close to your own gateway.

2 Likes

First of all, thank you.
My main worry is not receiving all my packets in my gateway, it is not critical if someone receive them.
The node and the GW are in the same room (just developing the app). Is it really close? They are in the opposite cornes in a big room.
Thanks.

Recommend >5 wavelengths seperation from node to GW (otherwise operating in near field vs far field) and better yet >3m, even in another room with additional attenuation through walls, doors etc. Esp if Tx’ing at full power as GW f/end may saturate and signal may be perceived to be detected on multiple channels causing errored packets and failed MIC checks. You should be able to see if all you packets are coming through (irrespective of GW receiving) if you look at the message fcount for your device :wink: As Arjan says ‘its radio’ so some packet loss is to be expected based on other users/interferers so dont expect 100% all the time :slight_smile: Also depending on GW used and packet forwarder you may find messages get lost between the GW and the NS - especially if running with a UDP based packet forwarder…‘its the internet’! :wink:

I often have a gateway about 3m distance from nodes during development and have not yet had issues with that.

Have you tried to check if you see anything coming in on your gateway in the gateway Traffic tab on the TTN Console?

Yes, of course. I receive some messages(maybe 1 of 5) but not all in the Traffic tab.

Please be more specific.

Also, in the application tab, my GW doesn’t appear in the Metadata in the messages I don’t receive. There is another GW with even better SNR and rssi than mine, how can it be possible?
Thanks!

In my application data I have all messages that the node sends. In those messages I can see other GW (not mine) in the metadata with better SNR and rssi than mine (when I receive messages in my GW, obviously) which is so strange. However, not all of those messages are shown in my gateway traffic tab, just 1 of 5 more or less.

Most likely your gateway has an issue like bad antenna connectors or similar. Can you tell RSSI and SNR of the messages received by your gateway?

SNR: 11.5 and rssi: -53

Thats quite strong and good and typical of ‘in room reception’ - in similar circumstances with +14dBm Tx I see typically values ranging from -28 to -65 for RSSI (mostly -45 to -65 depending on respective antenna orientation etc.) in a room perhaps 5m-6m max :slight_smile:

1 Like

What kind of gateway do you have (manufacturer and model)?

Do you have a single channel gateway?
It could explain why you don 't receive all the messages transmitted by your node while other multi channel gateways are picking them all.

Good point.

I’d like to remember that Single Channel G… is a deprecated (understatement) and incorrect phrase.

See: A Single Channel Packet Forwarder is not a gateway [guidelines]

I am using a Multitech Conduit IP67 AEP. It has been working nice for months, receiving all packets with no trouble. Just having problems since two days.
Thanks everybody for the time.

Ok, I have been investigating and had some conclusions.
The other gateway that appears in the metadata is the same gateway that I am using, but with the hardware ID. In the multitech configuration panel I have selected packet forwarder mode and vinculated to TTN.
So, currently, I have like two packet forwarders working with TTN.
However when I select the network server mode and obviously, the TTN packet forwarder installed and working, I loose a lot of packets in the way.
I am working with firmarware 5.0.0. May it be the problem?? I have to say that TTN installation guide is very poor as it says nothing about lorawan configuration in the Multitech wizard…
Some help? Thanks!

Once you installed the TTN software you should not use the MultiTech wizard at all. Local network server should not be used.

Ok, so what can be the problem? I install the packet succesfully and whatever is selected in the wizard, the behaviour is not the desired…
Maybe the firmware?? Does TTNpacket work with all GW updates?
Thanks

You should install the software and ••not•• use the wizard at all for LoRaWAN settings. Only run the installer for the software.

That’s what I do. I install the packet and “forget” the wizard. But it doesn’t work the proper way and I don’t know where the problem can come from.