Can you connect a new gateway to V3 yet?

I have tried to connect a new gateway based on the RAK2245 Pi_HAT and already have another TTN gateway connect to V2, which works fine.

After following the “add gateway” tab in V3, I entered all the relevant parameters. However, I have not been able to connect - the status is showing “disconnected” in the overview tab.

After looking back through the forums I am unclear as to whether it is possible to connect a new gateway to V3 as yet. Is this the case?
If so, are there any pointers as to what I am doing wrong/

Also, if I delete the gateway, and try to connect it to V2, will it result in a bricked gateway?

This is not a gateway migration, rather the connection of a new gateway to V3 directly.


1,547 gateways currently connected to v3:

Did you tell your gateway where to send the data for v3?

Short answer is yes it is and many of the posts you should have found would discuss this and the associated successful registration and operation.

As of tonight the status page shows some 1500+ GW connected and currently active on V3

Many will be migrated, many are new installs. Indeed I had no significant problems installing a new GW of my own a couple of weeks back. As yet I have not tried to migrate any of my existing RAK/RPi based GW’s from V2 to V3 (as guidance is migrate GW’s last) though new installs are fine for going straight to V3.

Can you tell us more on what you have tried, how you have registered, where in the world are you (which cluster have you registered to etc.) What do your GW logs show wrt connectivity, traffic etc.


1 Like

Thanks for getting back so quickly. That’s a relief!

I didn’t notice a setting in the RAK2245 that covered where to send the data…would that be contained in the “edit packet forwarder config” file in the setup for the RAK2245?

What information should I be adding?


Hello all again.
I have configured the Gateway EUI, name and ID (both text stings).
Gateway server address (
Authenticated connection not checked.

Europe 863-870Mhz frequency plan.
Schedule downlink late enabled
Duty cycle not enforced (as yet, for test).
Scheduled any time delay 0.53 secs

I don’t have any activity showing at all, with the exception that if I change any parameters, it is reflected in the activity log (Gateway updated).

I am located in London.

Then it should be receiving traffic.

Do you have your own device?

^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ ---- this!!!

How do you imagine your Pi knows what to do with all these radio signals being received? You can type anything you like in to the console, but if you don’t tell the gateway where to send its information, there’s no link to TTN.

Duh, I may have missed this - is this the part of the setup that I need to look at (see pic. below)?
What would be the IP address of the TTN V3 server?
There was a setup screen that allowed you to setup “server is TTN” and I assumed that it obtained the connection information from there.
Another assumption was that the following screen was for self hosted servers…


That’s you installing the ChirpStack which is not what you are aiming for.

You need to edit global_conf.json with the address shown on the console as I don’t think RAK has put the new v3 addresses in yet, but they do have screen shots on their docs site.

Thanks for that - it is becoming clearer now. The correct address that needs to be put into global_conf.json should be as show below?

Would that do it?

yes :+1:

I have edited the file global_conf.json found here in the RAK gateway O/S
with the correct address. The edited file is shown below:
Are the port addresses correct?
(I have replaced all the zeros shown in the Gateway ID with the correct value from the overview field in the TTN V3 console)

It is still showing disconnected. I have rebooted and also re-logged in to TTN V3.

I seem to remember that the you may have mentioned that the “disconnected” indicator is somewhat unreliable - do I need to send data to it from a node?

Finally, I have migrated one node from TTN to TTN V3, which i can see in an application created in V3. But I can’t see the data going through the RAK gateway. Is this to be expected because it is being forwarded from the old style TTN?

Wrong for V3… use forum search you want eu1… per console log in etc.

Apologies, I did use,
I included the file before update!
Still no joy at the moment.

Will check the forums for any other addresses…

I know it says gateway_ID, but I think you need to put the gateway EUI values in this field.

Check for a file called local_conf.json in the same folder the global_conf.json is stored. Any values in local_conf.json override the settings in global_conf.json.

Thanks, I’ll drill down a check for this directory too - I noticed that there seem to be several files that require this information!

@Mark, I’ll try the EUI values too.
Good info! Thanks.

1 Like

I’m confused. You post the address as show in the v3 console and then type something different in to the global_conf.json so it’s sending data to the wrong server and there’s a question about not showing connected in v3!!!

It is the v2 console that has an unreliable indicator, v3 is OK.

Please don’t, the ones on the v3 gateway console are the correct ones.

Have you spotted this:

Screenshot 2021-05-14 at 11.43.50

Which will tell you the exact settings you need!!!

Per @mark_stanley, gateway_ID is the EUI as entered on the v3 gateway console - as seen in the download file.

As @kersing suggests, check that none of the entries are being overridden in the local_conf.json - either make the settings the ones that the really handy gift wrapped download provides or remove the entry in local.

I’ll be back in the office on Sunday, I have one of every single RAK gateway so if you are still struggling then, I can look at the settings I have.

Yes, I did notice the file - the relevant part is shown below. Apologies if I confused you from my earlier post.

“gateway_conf”: {
“gateway_ID”: “xxxxxxxxxxxxxxxx”, <—Set to correct value from Console
“server_address”: “”,
“serv_port_up”: 1700,
“serv_port_down”: 1700,
“servers”: [
“gateway_ID”: “xxxxxxxxxxxxxxxx”, ← ditto above.
“server_address”: “”,
“serv_port_up”: 1700,
“serv_port_down”: 1700,
“serv_enabled”: true

The “xxx…” in Gateway ID has been populated with the Gateway EUI from the console, which was supplied by the RAK setup menu.

I can’t check local_conf.json now. I think that it was OK, but will double check later.
Many thanks.