Cannot connect to MQTT over the port 8883


we’ve deployed the TTS Open Source version 3.13.3. If we try to connect via MQTT over the port 1883, it works like a charm. But, if we try to do the same over the port 8883. We’re stuck and we don’t know what to do to solve the problem. We’re aware that this is very generic but we don’t know what to loop up.

Thanks in advance. Any help to point us where to look up will be really appreciated.

You may need to explicitly set the capath and protocol version parameters.

Assuming that you are using Mosquitto with MQTT bridging:

In mosquitto.conf to the bridge settings add:

bridge_capath /etc/ssl/certs
bridge_protocol_version mqttv311

(Above capath works for Home Assistant (OS) but may require a different value for your OS/distribution.)

1 Like

When asking for help on the forum and getting response from other users with solutions/suggestions but not let hear from you again (whatsoever) is disrespectful.
This is not how it works on the forum and does not motivate users to invest their time in helping others a next time.

This fixed my issue! Mosquitto logging is a bit poor and doesn’t tell you much except if you have connection status you will see that status = 0.


1 Like

@bluejedi Please, excuse me. We solved the problem by connecting via port 1883 and I totally forgot I had asked this question on the forum.

1 Like

Thanks for letting know how you solved it.

Unless this is all within a closed firewalled network, or over a VPN, you really don’t want to do that.

MQTT sends access credentials in cleartext, so in the real world you need to be using the MQTT-over-SSL port 8883, which means you need to figure out the certficate / chain / validation or even clock issues that are preventing that from working.

1 Like

@cslorabox thank you very much for the advice. We are testing it but we have already taken into account all those details that you have mentioned. The next thing we want to achieve is using port 8883, but first, we need to learn how to configure and resolve all the issues with certificates/chains etc.

Thanks again, I really appreciate your comments :wink:

@bluejedi Sorry again and thank you very much for your help and your comments.