Can't get the Mikrotik LR8 connect to TTN

Hi !

Sorry to ask for help or double post, but my knowledge on router configuration is not that good and I have still not managed to get it connected to TTN EU network. Similar posts did not point me in the correct direction.
Here is my configuration:

feb/17/2021 10:28:49 by RouterOS 6.48.1
software id = TI2K-C6NS
model = RBwAPR-2nD
serial number =
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-XX
country=austria disabled=no distance=indoors frequency=auto installation=
outdoor mode=ap-bridge ssid=MikroTik-B8825D station-roaming=enabled
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk mode=dynamic-keys
supplicant-identity=MikroTik wpa-pre-shared-key=
/ip pool
add name=dhcp ranges=
/ip dhcp-server
add address-pool=dhcp disabled=no interface=wlan1 name=defconf
/lora servers
add down-port=1700 name=TTN-US
add down-port=1700 name=TTN-EU
add down-port=1700 name=TTN-EU-open
/ip neighbor discovery-settings
set discover-interface-list=LAN
/interface list member
add comment=defconf interface=wlan1 list=LAN
add comment=defconf interface=ether1 list=WAN
add list=LAN
/ip address
add address= comment=defconf interface=wlan1 network=
add address= interface=ether1 network=
/ip dhcp-client
add comment=defconf interface=ether1
/ip dhcp-server network
add address= comment=defconf gateway=
/ip dns
set allow-remote-requests=yes servers=,
/ip dns static
add address= comment=defconf name=router.lan
/ip firewall filter
add action=accept chain=input comment=
“defconf: accept established,related,untracked” connection-state=
add action=drop chain=input comment=“defconf: drop invalid” connection-state=
add action=accept chain=input comment=“defconf: accept ICMP” protocol=icmp
add action=accept chain=input comment=
“defconf: accept to local loopback (for CAPsMAN)” dst-address=
add action=drop chain=input comment=“defconf: drop all not coming from LAN”
add action=accept chain=forward comment=“defconf: accept in ipsec policy”
add action=accept chain=forward comment=“defconf: accept out ipsec policy”
add action=fasttrack-connection chain=forward comment=“defconf: fasttrack”
add action=accept chain=forward comment=
“defconf: accept established,related, untracked” connection-state=
add action=drop chain=forward comment=“defconf: drop invalid”
add action=drop chain=forward comment=
“defconf: drop all from WAN not DSTNATed” connection-nat-state=!dstnat
connection-state=new in-interface-list=WAN
add action=accept chain=input in-interface=ether1 protocol=udp
add action=accept chain=output out-interface=ether1 protocol=udp
add action=accept chain=input in-interface=ether1 protocol=tcp
add action=accept chain=output out-interface=ether1 protocol=tcp
/ip firewall nat
add action=masquerade chain=srcnat comment=“defconf: masquerade”
ipsec-policy=out,none out-interface-list=WAN
/ip route
add distance=1 gateway=
set 0 forward=crc-valid name=OE1KFR_GW servers=TTN-EU-open
/system clock
set time-zone-name=Europe/Vienna
/tool mac-server
set allowed-interface-list=LAN
/tool mac-server mac-winbox
set allowed-interface-list=LAN

I added port forwarding for port 1700 udp and tcp on my ISP router in client mode.
I also added in the firewall of the mikrotik that udp and tcp is allowed on eth1.
But still no luck to get it connected to TTN.
Any help would be much appreciated.

One of our community members reported the same issue yesterday. They have multiple Mikrotik gateways installed, and a similar configuration as yours always worked. But a gateway installed yesterday did not want to come online on TTN V2.

After resetting the mikrotik lr8 configuration with option to not generate the default config we managed to get it first connected to V3. No chance to connect it to v2. Now after two days in V3 it is also active in V2 without any interaction or changes.
So it is running now…

What do you mean, that have one single gateway connected to V2 and V3?

Yes with the Mikrotik Lora8 Kit and when you configure it with the winbox you can define two or more servers in parallel to forward the packets.
you can see in the screenshots, that it is online on both:
Bildschirmfoto 2021-02-20 um 18.23.51
Bildschirmfoto 2021-02-20 um 18.24.56
As i am currently not at home and still don’t have a vpn connection to the home network I have no screenshot of the winbox config of the miktrotik wap.

I’m having the same solution: connected to both - V2 and V3.

Is there a working example for configuration on both sides? I was trying to register new gateway on V2 and V3 witgout success. The V2 is OK, but has Status:unknown for the gateway and in V3 I got error: ID taken.

Here is my configuration:

[admin@mtik_LoRaGateway] > export hide-sensitive

may/31/2021 19:29:02 by RouterOS 6.48.3

software id = BS0G-I4NA

model = RBwAPR-2nD

serial number = C0220B14ED28

/interface bridge
add name=bridge1
/interface wireless
set [ find default-name=wlan1 ] antenna-gain=0 country=no_country_set frequency-mode=manual-txpower mode=
station-pseudobridge ssid=MikroTik station-roaming=enabled
/interface ethernet
set [ find default-name=ether1 ] advertise=10M-half,10M-full,100M-half,100M-full,1000M-half,1000M-full
/interface list
add name=WAN
add name=LAN
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/lora servers
add down-port=1700 name=“TTS Cloud (eu1)” up-port=1700
add down-port=1700 name=ttn-v1 up-port=1700
/user group
set full policy=“local,telnet,ssh,ftp,reboot,read,write,policy,test,winbox,password,web,sniff,sensitive,api,romo
/interface bridge port
add bridge=bridge1 interface=wlan1
add bridge=bridge1 interface=ether1
/ip neighbor discovery-settings
set discover-interface-list=!dynamic
/interface list member
add interface=wlan1 list=WAN
add interface=ether1 list=LAN
/ip address
add address= interface=ether1 network=
/ip dhcp-client
add interface=bridge1
/ip dns
set servers=
/ip route
add distance=1 gateway=
set 0 disabled=no servers=ttn-v1 spoof-gps=45.801832/15.178757/222m
/system clock
set time-zone-name=Europe/Ljubljana
/system identity
set name=mtik_LoRaGateway

V2 console:

When I change last digit in ID from 0 to 1, I can register new gateway in V3. I changed server to
but the GW is not connecting…

Is there something I have to configure additionally to the settings described here:
or here:


Or it just takes a very long time to connect?

Meanwhile during my typing some packets arrived:

But the status of the GW is “unknown”.

Should there be some log in the “traffic” for the server connection ?

There is no point registering with two different systems as you can only tell the gateway one place to send the uplinks without getting in to rather advanced settings, v2 & v3 traffic are shared between the two and one will be shut down in the near future.

Have you read the sticky note at the top of the forum about v2 console status?

v3 only shows connected once it see traffic.

Please can you format you post, see this for info:

Does that mean, my Mikrotik Lora8, laying on my table indoor with no Lora signal around, can’t show connected until an signal is received? For example a not connected temp device…?

tnx for help…

I haven’t retested since new releases of the stack, but I saw my gateways saying not connected even though it was showing stat messages. Once an uplink arrived, it showed as connected.

But you can try this.

A LoRaWAN gateway in a forest won’t show connected if the end-device isn’t powered & transmitting.

OK, so there’s a chance that i’ve configured it alright.
For my 1st tests, i’ve an ERSCO2, but that is connnected to another server outside TTN…

Seems not to connect… On my Mikrotik i can see the traffic, but nothing on TTN. Whats wrong. Should i have to use the “” server??



What seems not to connect?

If the ERSCO2 is not registered on TTS then you won’t get anything more than some rejected traffic.

But your screen shot doesn’t show any stat messages. Your screen shot does show the address for the gateway server.

Damned. Found ist. On my Mikrotik i added .industries, but in TTN there is by default .network… omg…Sorry.