Denied when using OTAA


We are using RN2483 with ATmega644PA. Located in EU, running on 868 band, antenna is DELTA6A/X/SMAM/S/S/11.

sys reset
RN2483 1.0.3 Mar 22 2017 06:00:42
mac get deveui
<deveui, enters this into device registration>
mac set appeui <appeui>
mac set appkey <appkey>
mac set adr on
mac save
mac join otaa

There are two gateways nearby. It always says denied, however, at what seems to be completely random - about 1 out of 20 times - it will create a new entry in the application data tab under “activation” in the TTN console, but the module still returns “denied”. :thinking:

What is an acceptable/normal RSSI? What could be causing this behaviour? Lack of signal?

Set your data rate to something other than SF12. Some RN2483 modules have issues joining on SF12.

Thanks, will go test that. :slightly_smiling_face: Any setting specifically recommended? Should SF11 work fine?

Went out and tested it. Tested SF10, SF9 and SF8. Nothing worked. Very rarely an “activation” data entry was created but we still constantly get “denied”.

If TTN receives the OTAA Join packet and the EUIs and keys are okay, then such should be visible in TTN Console for each join attempt, if you have TTN Console open at the time of the join. (Or it should show an error when re-using security nonces.)

So seeing it only “very rarely” implies that your EUIs and keys are okay, but that your node is often out of reach of gateways. Also, for the few cases where you saw the activation in TTN Console, apparently the subsequent Join Accept was not received by your node, so again the node was out of reach (or not listening at exactly the right time).

I’d first focus on ensuring TTN gets the OTAA Join Request for each and every attempt. Or, test with ABP first to ensure you’re in reach.

(As an aside: “denied” only tells you that the node did not receive a reply. It’s not telling you that it was truly rejected, as LoRaWAN does not send such rejections at all.)

1 Like

there was a problem last night … I was in the middle of testing things and couldn’t join otaa.

at the moment it’s working ok as far as I can see

Hello @Foorack, It may be a very stupid question, but are you sure that the two gateways in the nearby are true multi-channel gateways? Because if they are single channel ones, then they are simply not able to receive on all the LoRaWAN specified channels that your node is transmitting on…

1 Like

The same is happening to me…
I tried with ABP, it’s working but OTAA giving problem…Previously It was working with SF7BW125 but when I changed it to SF12BW125 after that even I get back to original setting still the same reply is coming i.e. denied