DRAGINO problems and solutions topic part 1


(Glbaum) #160

My guess from a simple bit of deduction is perhaps from Objenious/Digimondo. From the Address Space link you shared @BoRRoZ:
0x28/0x29` Germany, Switzerland, China: DIGIMONDO GmbH (0x14)
and this press release:

@kelu28 The reason BoRRoZ made that comment is clear from the link he shared. The information you shared from your console doesn’t match a device that’s Dev EUI was created by TTN. It also doesn’t at least from my reading make it the issue of your problem. But when you set up/added the Device to your console did you input the Dev EUI for your node or did you allow TTN to create it for you? The documentation states it should be something other than x28 which is why BoRRoZ made the comment he did. Just my 2-cents and thoughts though.


(Kelu28) #161

:slight_smile: I am born the 28 November 1982, And i put the dev_eui by my self ! Must I change this value?


#162

see https://www.thethingsnetwork.org/docs/devices/registration.html


(Kelu28) #163

So, read the link.
make:
“If you plan to switch to ABP anyway, click the button have one generated for you”
I make it, but the TTN website give me the same Dev EUI.
And naturaly no change.
Have you another idea?
What must I do?


(Kelu28) #164

I have contact the dragino support.
They ask me to update my LG01.
Make it but not the solution.
I think the error come from the DEv EUI.
But how to solve it?
my actual parameter for ABP:

DevEui= 00 04 A3 0B 00 1F D3 95
DevAdd= 26011A96
NwkSKey= 95 78 A6 B0 AD 5E 50 BC 1C 40 83 5B 23 56 2B 9C
AppSKey= 3A 66 2E 1B DE 3C 25 E3 29 30 FD E4 2D B6 0B 5A

please help me !


#165

ok show us your code (and please format)
we must see the AT commands you send … see wiki


(Kelu28) #166

Thanks to help me.
First I make a AT+FDR
then disconnect the jumper and reconnect it.
SW1 is in flash mode
then:
My AT command:

AT+TDC=30000                            
AT+NJM=0
AT+TDC=10000
AT+APPSKEY=3A 66 2E 1B DE 3C 25 E3 29 30 FD E4 2D B6 0B 35
AT+NWKSKEY=95 78 A6 B0 AD 5E 50 BC 1C 40 83 5B 23 56 2B 9C
AT+DEUI=00 04 A3 0B 00 1F D3 95
AT+DADDR=26 01 1A 96
AT+APPEUI=70 B3 D5 7E D0 01 2E C3
AT+JOIN

Each time, the LSN50 say “OK” and finally “Joined”. But on my LG01 gateway I see a join request from the LSN50. Why? I am in ABP mode?
Next I do a reset and the LSN begin to speak in ABP on the only one channel of the LG01, but the gateway never hear anything.

In parallele, if I send AT commands to the LSN50 in order to use OTAA mode and connect to the Objenious Lora network, that work!..

Finally I don’t understand what I make false. Help !


(Luiz H. Cassettari) #167

Hello,

I have a Dragino LG01 gateway too, and oh boy… They did some shit when designing this gateway.
It’s improbable to get a LoRaWAN downlink from this gateway.

You can check the open source code if you understand what’s going on there. :stuck_out_tongue:


The code doesn’t care about any timestamp, that’s mean the gateway doesn’t know the right time to send the downlink to the node.

Usually the node open RX1 and RX2 on a specific time after sending the message, and if the gateway doesn’t have a good time synchronization the device never receive any downlink.

Summarizing… The Dragino LG01 downlink doesn’t work, that’s mean only ABP uplink…

I probably gonna make a code trying to fix this.
Stay tuning! :metal:t2:


(Antonionardella) #168

That would be awesome, I am struggling since August to get the downlink working and could not understand why.


(Wpapendick) #170

Hi there.

Hope you can help me.

I cannot connect to TTN, tried a lot, several times but the gateway does not connect to TTN. I do not see the global LED working.

Never seen ;-(

Would be really appreciated if you can help me.

Thanks in advance.

Wolfgang


#171

Hello Wolfgang,

A few more information about your setup. I think you have a card or device off DRAGIO but we need more info else we can’t help.

Johan


#172

I just installed a “DRAGINO Lora Gateway” LG01-P and connected to the TTN network.
Connection is good and the first data from nodes are tranferd.
image

This gateway/router is from the DRAGINO “LoRo IoT development Kit”
I put it in the LAN connection mode on my home network.

Comming day we will see if it work’s with the other “Nodes” in to the box Arduino-UNO based.

Johan


(Jackkc7vlo) #173

I know this is old, but for those who find it, it can be set up.

http://wiki.dragino.com/index.php?title=Connect_to_TTN


(Shwetal) #174

are you using 3.3v pin or 5v pin ? It will be working perfectly at 3.3v


(Wpapendick) #175

Hi Johan,

thank you for your reply.

I just installed the LG-01 S like the Wiki said:
[http://wiki.dragino.com/index.php?title=Connect_to_TTN]

I tried both, the configuration with WAN-port and with WIFI-client. But nothing happens. Drives me crazy.

Do I need to upload also an Arduino scetch to the LG-01? And do I have to start the packet forwarder on the LG-01? If yes, which version and how can I do this?

Thanks in advance.
Wolfgang


#176

Hello Wolfgang,

I have install it with out WAN or Wifi, but connected to the first lan port with a static ip adress on your own lan. (think on the right mask and gateway)

After that we go futher

Yes you need to upload the scetch I used version 4 off it
image

And then you need to start packetforwarder to LORAWan, as given in the Wiki page.

Regards

Johan


(Wpapendick) #177

Hi Johann,

thanks.

I have successfully uploaded the hex-file but how canI start it now?

Regards
Wolfgang


#178

Hello wolfgang

as in the Wiki

Check this first
image
and then
image

After that choose the right service you wan’t
image

then you must that your gateway will be come online

Succes

Johan

But with other word’s following the WiKi step by Step :slight_smile:


(Wpapendick) #179

Sorry, but no success. Grrrrh

image

I will do the complete procedure again. Including the TTN.

Will write again. Hopefully with success.

Thank you.


(Shwetal) #180

is the dual channel pkt code applicable for (raspberry pi 3b+ and dragino hat v1.4) or we have to use the particular hardware ?