Dwell Time Restriction

In V3, I don’t think I have the ability in the console to enable/disable the dwell time restriction.
In my region there is no max dwell time of 400ms and the restriction is causing excess packets being sent when they exceed 400ms.
This is because some nodes I use will break the payload apart and send in chunks when they are going to exceed 400ms. So instead of sending one payload, two are sent, costing more time on the network…
The extra battery consumption is going to reduce battery life by a measurable margin.

Also my application would have to cache and re-piece the packets together which causes extra complication and processing on the ingestion side. It would be also good to not have to build this extra code.

Is there a hidden ability or planned ability to send mac commands to disable the dwell time? This would be very useful to have such control in TTS.

The MAC commands to disable dwell time should be sent automatically in regions that don’t have a dwell time limitation.

This regional configuration is done in frequency plans. See https://github.com/TheThingsNetwork/lorawan-frequency-plans for more details, and feel free submit an issue for a frequency plan for your region.

I’m able to see MAC command TxParamSetupReq being issued, looking like this:

{
@type”: “type.googleapis.com/ttn.lorawan.v3.MACCommand.TxParamSetupReq”,
“max_eirp_index”: “DEVICE_EIRP_16”
}

While the console doesn’t show the raw payload, we can see the JSON definitely does not contain dwell time information. This may be simply missing from the JSON renderer, but it would be useful to have it, without it does make it hard to error-check if the correct dwell parameters are being sent.

Note: my nodes don’t display raw rx data so I can’t check if bit 4 and 5 are being set to 0 or 1.