ELSYS LoRa® ERS / ERS-lite

Hmmm, interesting - looks like my ERS sensors (ERSgrid / ERSeye) also don’t accept config changes over LoRaWAN.

I tried to reconfigure the SplPer and SendPer with a downlink message to port 6 (including a reboot command, payload created with Elsys downlink generator) but no reboot seen and sensor stays at the old sample & transmit periods.

Last test was against a sensor running firmware 2.2.7. I also tried a confirmed downlink; after that one, the sensor was lost completely, so I’ll have to go out and try to fix it on-site.

When I manually send a downlink message to my Elsys ELT2 through TTN it almost never works.
However, when I send a downlink message through AWS IoT Core MQTT client with the options:

  "port": 6,
  "confirmed": false,
  "payload_raw": "AQIDBA=="

‘confirmed’ = false it always works.
It seems like TTN will always send downlink messages as confirmed even when you have not selected the option.


Never run into any of these problems - configured many an Elsys and Zane products over the air with no issues.

Are your gateways 100% transmitting the packet?

Hi, I am using a Raspberry Pi with IMST iC880A and trying to connect Elsysy ERS into the network. I am using the semtech gateway and packet forwarder.
ABP mode is working as expected but in OTA mode its failing to complete the join processs.
In gateway logs I am getting the uplink message(join request) from the End node and also the downlink message(join complete) from network server, But Again I am getting the join request from End node.
Is any logs I will get in Elsys ERS to check whether its getting the downlink messages or not??? And how to check that logs??? is there any another way to debug on node side???

Strange. We are using a MatchX Gateway, and also at home I have a Tektelic. Never ran into any issues at all with the Elsys. OTAA works perfectly. All I can think is something is off in your global_config.

… Come to think of it - how far is the node from the gateway? Sometimes if they are too close you can run into issues.

What behaviour did you experience when the node was too close to the gateway?

It would receive a packet on multiple channels simultaneously… And OTAA seemed to take a few transmissions to settle. This was about 5m distance.

I am having a similar problem, downlink message are not doing anything. Whats strange is if I hard reboot the node then the message seems to get processed when the node comes up. Its very annoying so wondering if anyone ever figured out whats happening. I have other nodes where the Downlinks work just fine.

Solved the downlink issue by always issuing a reboot in the commande.

But so sad to report that I am having a terrible support experience with these guys. I bought a sensor direct from them which is supposed to work with a Maxbotix MB7360 and I have tried for days to make it work, but it does not. This should have been straight forward, they provide a wiring diagram and NFC based setup tool.

Their support replies like once every 3 days so I have been waiting like a week now for some answers and still nothing. Sent a reminder email 2 days ago and no answer :frowning:

1 Like

In their configuration app there are two different MaxBotix sensors you can select when configuring the external input. Did you try both options?
If both options don’t work you can connect the MaxBotix sensor as analog input en read the data that way.

I have tried both, one does not store the setting at all (22) and the other (13) saves but I get an output error code…

Currently doing it as an analog input and that works.

I got a hold of them this morning via phone and will test the new beta firmware to see if it works better.

Thanks for your help.

My experience with ERS-lite was that after updating OTA the sensor would stop working but works ok when updating with the phone app. In my case the unit is located in a locked facility in a remote location without ready access so relying on the phone app is not great.

1 Like

I had this issue… was due to not including the Reboot command in the payload. oops.


I would like to buy Elsys ERS Eye. How do we change the channel configurations?

Hello, i’m testing many of these sensors including ELT2 and ERS on AU915, while they do transmit, they have terrible RSSI to my gateway (about -115dBm) at about 5 meters, while other sensors have -40dBm at the same distance, thay also seem to fail to deliver a lot of packets, frequency confguration is ok, and at least on ELT2 i’m using the proper antenna.

Any ideas?

Strange. Have the ERS’s -90 -100 RSSI at 2 miles. EU 868mhz

I read this post and realised I was not ticking the reboot option on the downlink generator. Ticked it this time and my downlink updated settings worked.

Thank you, Rob (Cornwall)

1 Like

How you getting on with the ELSYS products? Our are over a year old now. Flawless in our properties.

Sorry, I missed this in January!

Love the Elsys sensors. Easy to configure, robust & reliable.


Hi everyone, I have an ELSYS ELT-2-HP with a Maxbotix ultrasonic sensor and I can’t get the ultrasonic sensor to work.

The device has been configured using the ELSYS NFC app all ok. It is joined and uplinking all ok. The uplinks report correct data for the environmental sensors, e.g.:

“temperature”: 20.8,
“humidity”: 40,
“vdd”: 3611,
“pressure”: 1005.568

Nothing from the Maxbotix at all.

I have configured the Maxbotix via the NFC app and tried both types of external Maxbotix sensor types listed and also set the timers on the external interface. See picture below for example.


Nothing that I have done has caused anything to appear in the uplinks for the ultrasonic sensor. I’m very careful to make sure that the NFC app successfully writes to the device when I make changes and that the device re-starts and re-joins. It always does, all ok.

I have noted that the Maxbotix ultrasonic horn is labelled MB 7389 on the inside.

Does anyone have any insight into what I’m doing wrong or missing?