Firewall Settings and "gateway_ID"


I have setup a Kerlink IoT Station as TTN Gateway.
The good message is, that I’m able to join a Node by OTAA over this Gateway. The node ‘last seen’-status gets updated accordingly.

The bad message is that the gateway’s status remains on not connected in the console.


  • shouldn’t the gateway_id within the local_conf.json be adapted to the Gateway ID set under the gateway’s settings on the console? If so, why is that information missing within the documentation?

  • I assume that the network hosting the Gateway should allow outward UDP Traffic on port 1700. What other ports should be reachable and therefore require adaptions on the firewall?

Many thanks for your support.

The documentation seems to be rather incomplete. I somehow collected all missing pieces to get the full picture on the Kerlink’s configuration.

The generated local_conf.json seems to be incomplete. I somehow miss the Link to what I have registered within the console. In Kersing’s repository for the Poly Package forwarder I found a local_conf.json,sample which looks to be more complete.

/* Put there parameters that are different for each gateway (eg. pointing one gateway to a test server while the others stay in production) */
/* Settings defined in global_conf will be overwritten by those in local_conf */
    "gateway_conf": {
        "gateway_ID": "CHANGE-ME", /* you must pick a unique 64b number for each gateway (represented by an hex string) */
        "contact_email" : "CHANGE-ME",
	"description": "CHANGE-ME",
	 "servers": [
                "serv_type": "ttn",
                "server_address": "<see TTN console>",
                "serv_gw_id": "<gateway name from console>",
                "serv_gw_key": "<gateway secret key from console>",
                "serv_enabled": true           
	"gps": true,
        "fake_gps": true,
        "ref_latitude": CHANGE-ME,   /* put your latitude here */
        "ref_longitude": CHANGE-ME,  /* put your longitude here */
        "ref_altitude": CHANGE-ME

serv_gw_id and serv_gw_key are the parameters from the gateway’s entry on the ttn console.
In case you have already misconfigured gateway_ID as I have done it, you can re-generate a new ID by using this script.

Now I hope the getaway becomes active on the console.

Can you perhaps clarify which packet forwarder you are using, or which instructions you used. You are mixing up different one’s configuration here. If I know which packet forwarder you are using, I can tell you which config value you should use.

Thanks. Meanwhile I realized that there are several package forwarder used and described. I also noticed that a new package forwarder got released recently (12d ago).

Initially I followed the official documentation here. This guide links to a binary of the TTN Package forwarder V1.3 which has been committed a year ago.

Thus I assume that I’m using the V1.3.

After you did the first step in that tutorial, you have a .log file on your usb flash drive. Apparently the EUI of the gateway will be written somewhere inside this logfile. Alternatively the EUI is written on the outside of the gateway enclosure.

When you have the EUI, which is a 16 HEX character code, you can use this to register the gateway on the console. When registering the gateway, choose I’m using the legacy packet forwarder. Then the text field above it will change from “gateway id” to “gateway eui”.

I don’t see any mention of the local_conf.json file on the kerlink. But in theory the gateway_ID parameter should have the value of the EUI.

Sounds all reasonable. I redeployed the forwarder to my Kerlink.

The EUI marked in the logfile was only 4 bytes long. I used that one from local_conf.json.

Now the TTN-Console fails to register the gateway:

Ok. The error was because of the empty position data (latitude, longitude). It finally worked and I could add the gateway.
I then have joined a node and sent some message. The weird thing is, that the messages are coming through but the gateway status remains as not connected

You can see from the two screenshots that the gateway id’s are different. So either another gateway is receiving your packets, or your real gateway EUI is different.

Registered as: 0000024B08030454
Received by: FCC23DFFFF0DEA72 (Located in Luzern)
(yes, I just typed those over from your screenshots)

Seems that I was talking to a stranger.

Hi @jpmeijers and @maus,
thanks for this post, I have the same problem right now. I use the Kerlink Wirnet 868 as well and I did that too:

But in the Console the Gateway is still not connected…
Have you solved it?

Thanks for your help!