Gateway receiving in wrong Frequency band?

I have just setup and activated a new full gateway that is based on a LoRa Gateway Developer Kit (with RAK831 LoRaWan Module with Raspberry Base Pi3 MAX-7Q GPS Module Base on SX1301 - freq for AUS/NZ on 915 MHz).
Up to now, before getting the full gateway going, I’ve playing around with a Wemos/RFM95 single channel gateway locked to SF7 on 916.8 MHz.

So I’ve got both gateways active and alive on TTN.

My problem is that when I use my test node that is based on Arduino Uno with a Dragino shield - still locked on to only one frequency (916.8 MHz) and SF7, then both Gateways will pick the transmission up (not at the same time necessarily), but the Single Channel Gateway shows the message coming in on 916.8 and the 868.3 or 868.5. All coming from the same device address.

So, my test node might not be as locked to the frequency as I thought it was, but what worries me more is that all the info printed on the RAK boards indicate that is the correct 915 MHz unit. I do not know if I missed something in the setup - but surely the 915 MHz unit should not be able to even receive 868 MHz messages?

Single Channel Gateway:
image

Full Gateway:
image

Anybody experienced something similar?

Do you ever see the same packet on both gateways? Do you see all packets in the application’s Data page?

A DevAddr is not unique. TTN will use the applications’ secret NwkSKey session keys to verify the MIC, and if it’s verified it knows which application can decrypt the application payload. So, even though the payload sizes happen to be the same (and the uplink counters are always zero?): are you sure these packets are sent by your node?

If you’re not sure: maybe a different node is actually sending on 868.x, and maybe your full gateway has erroneously been configured to use the 868 settings? (868 and 915 MHz use different antenna connectors, but maybe the hardware is capable to handle both, so using the wrong settings might be possible?)

Why not?

"The SX1257 is a highly integrated RF front-end to digital I
and Q modulator/demodulator Multi-PHY mode
transceiver capable of supporting multiple constant and
non-constant envelope modulation schemes. It is designed
to operate over the 862 to 960 MHz European, North
American and Japanese ISM (Industrial, Scientific and
Medical) license-exempt frequency bands. "

Can you please provide us with your json configuration files?

If I were you I’d try to force the node to set correct frame counter value.

Thusfar, I have not seen the same packet appearing on both gateways.

I can not say I am 100% sure that the packets are coming from my device, but I have not seen any other activity unless I have my test node active.
I will change the device id and see if the new id shows up in both gateways.

I did not realise these radios had such a range, and even if the same RF unit was capable of multiple bands, I would expect some filters tuned to limit the range to the specific band. I mean you have to select at ordering whether it should be 434, 868 or 915.

Will be happy to do so. Where do I find this?
I have worked through the setup guide that I found on the RAK web site, so I am not that familiar with these gateways yet.

Can you please explain a bit more on how this would potentially be done?

Filename is global_conf.json , guess you should be able to find it on your Pi filesystem with ‘find’ command.

Can you please provide me with the exact link? I see some readmes in their github repo, but not sure which one you have used.

Also, people have seen multiple receptions for a single signal:

I guess the 2nd bullet might apply, along with erroneously configuring the gateway to use EU868?

Though that would not explain:

So indeed, changing the DevAddr in your own node is a very good start.

Did a search “find global_conf.json” but that did not find anything. If I just use “find” then I get a file structure, so I will go through some of the directories manually today and see if I can find it.

Thanks Arjan, will play around with that more today and report back.

Hi Hobo,
Here is the document I used as a guide: RAK831-Raspberry-Pi3-Gateway-&-RAK811-LoRaNode-User-Manual

find / -name global_conf.json -print

and also

find / -name local_conf.json -print

I would expect that the filters on the RF input side would not be so sharp that a 915Mhz module would completly exclude all 868Mhz signals.

…which tells you to:

$ git clone -b spi https://github.com/ttn-zh/ic880a-gateway.git
$ cd ic880a-gateway/
...
$ sudo ./install.sh

The installation step will ask you if you want to enable remote configuration. Type ‘y’ or ‘n’ and continue with the installation. […]

Here we type ‘n’ for local configuration. If you want to use the remote configuration option, please make sure you have created a JSON file named as your gateway EUI (e.g. B827EBFFFE7B80CD.json) in the Gateway Remote Config repository here: https://github.com/ttn-zh/gateway-remote-config

Assuming you selected “n”, then without the .git suffix, https://github.com/ttn-zh/ic880a-gateway shows that install.sh executes, among many other things:

INSTALL_DIR="/opt/ttn-gateway"
...
pushd $INSTALL_DIR
...
git clone -b legacy https://github.com/TheThingsNetwork/packet_forwarder.git
...
ln -s $INSTALL_DIR/packet_forwarder/poly_pkt_fwd/poly_pkt_fwd ./bin/poly_pkt_fwd
cp -f ./packet_forwarder/poly_pkt_fwd/global_conf.json ./bin/global_conf.json

So, your global_conf.json should be in /opt/ttn-gateway/bin/global_conf.json. I guess its file permissions are such that you needed sudo find to locate it. Also, the above shows it’s taken verbatim from https://github.com/TheThingsNetwork/packet_forwarder/blob/legacy/poly_pkt_fwd/global_conf.json so I’m quite sure it’s using EU868.

Still curious if you’re seeing uplinks from another EU 868 node, or that your own AUS/NZ 915 node is too close to the gateway.

I have actually selected “y”, and created the following remote config:

I have tried to test again today with the same test node, but today I could not get any packets coming in on the new full channel gateway - only on the single channel gateway.

I also searched for the “global_conf.json” using the command @hobo supplied and found the following instances:
/opt/ttn-gateway/lora_gateway/util_pkt_logger/global_conf.json
/opt/ttn-gateway/packet_forwarder/poly_pkt_fwd/global_conf.json
/opt/ttn-gateway/packet_forwarder/basic_pkt_fwd/global_conf.json
/opt/ttn-gateway/packet_forwarder/gps_pkt_fwd/global_conf.json
/opt/ttn-gateway/packet_forwarder/beacon_pkt_fwd/global_conf.json

The only file I could access was this one:
/opt/ttn-gateway/lora_gateway/util_pkt_logger/global_conf.json

And yes, it had no 916 frequencies included in it. I updated the file to match this one:

But unfortunately it did not change anything.

So, now I have decided to redo the whole config. Busy with a new 16 GB SD card, formatted it and I am currently busy doing it all over again - but with one change, this time I will answer “no” when the question comes about the Remote Config because I could not remember specifying the AUS band at any point in time when I did it the first time around. I am not sure where that question should have come up?

Will update once I have new information.

Thanks for all the ideas and support - much appreciated!

As @arjanvanb already said, this one should be that what you need. Gues you have to start your editor with sudo command to be able to edit it.

From their docs it seems that this question will not be asked and you have to edit config manually.

@hobo, @arjanvanb,

Many thanks for your ideas and support!

I did the whole config over, but without the remote config (although that was not the problem).
After the install, I updated the /opt/ttn-gateway/bin/global_conf.json with the information found here https://github.com/TheThingsNetwork/gateway-conf/blob/master/AU-global_conf.json as it was still on 868 frequencies. And now I am happy to report that after the changes, the Gateway is working on the correct AUS/NZ frequencies. I will go back to my remote configuration as well and update it all in a similar fashion to make sure it all works that way as well.

As for my test node - need to look into it a bit more because there are definitely some dodgy activity as it is not just transmitting on the single frequency I thought I locked it on.

I have the same issue as above, I try changing to the 915 band in the gobal_conf.json file, but I am unable to save my changes as the file is locked. I’ve tried chmod 777 global_conf.json, but that doesn’t work either.
any ideas?

That’s too vague. Why are you executing the command you quoted? (Or: what command are you really running?) What’s the exact error? Did the chmod 777 itself fail or succeed?

If access is denied, then you might need to prefix the command with sudo, to execute it as root.

(As an aside: don’t use chmod 777; it’s making the file executable by everyone. Bad habit, even more so for a file that is meant as a configuration file, not an executable file, so would need 666 at worst.)

Hello,
please i am currently trying to build and 8 channel gateway with RAK 831 and raspberry pi3. I have setup the gateway and done the necessary steps as i observed above for 915MHz because in am in Canada. First the gateway came up and presume worked fine but i did not receive data from my nodes although it showed connected on the things network. after a while, the gateway was no longer seen as connected on the things network and i do not see any data coming in on the Log. what do i do from here.
Note: i am in Canada and am using the 915Mhz.
I am currently working on a paper where i need to apply this. your help will be sincerely appreciated