Gateway status:"disconnected" after migration from V2 to V3

Hi guys,

I have migrated my gateway from V2 to V3 through this guide: Migrating Gateways | The Things Stack for LoRaWAN
However the status still remain “disconnected”


I would like to know if any come across this problem and how you guys solve it. Really appreciate your help!

What does the gateway log say? Is it connected to the internet, the network server, receiving any uplinks?


Thank you for your response. I have solved my problem. I didn’t realise that I was in the wrong cluster, that’s why I couldn’t see my gateway from my end.

I have the same thing, but i think i also have the gateway in V2 registered. Is that a problem? My device data is also not arriving in V3, it does arrive in V2

It doesn’t matter if the gateway is registered in both, since it will only be pointed at one.

My device data is also not arriving in V3, it does arrive in V2

That suggests your gateway is actually still pointed at TTN V2 servers

You will need to change the config on the gateway as well as registering on the web.

When you say device data, do you have a device registered on v3 or do you mean gateway traffic on v3?

A gateway on v2 can receive uplinks for a v3 device. But a v3 gateway can’t do anything for a v2 device. So only transfer your gateway after you’ve moved your devices and please consider there may be others in the community that have devices that are heard by your gateway.

Hey there, I am having the same problem. Even my gateway seems connected on v2, it seems disconnected in v3. For a while I haven’t been receiving data to my application in v2 and I thought that it was time to migrate my devices to v3 however I am facing with this problem now. Do I have to delete the gateway from v2? Or could you tell me how to change the cluster on v3? The other inquiry of mine is, shall i migrate my application before my gateway? I have too many question minds as you understand :slight_smile: I would be glad if you help.

No. What matters is which you point the gateway at.

Basically, do not “delete” a gateway until you are absolutely sure you will never go back, as if you do it would take administrative intervention to be able to create that gateway again.

Hello, thanks for the answer. I haven’t deleted my gateway on v2. I still can not solve the problem on v3. Why it seems ‘disconnected’ on v3 while it is connected on v2.

A gateway that points to V2 will never be listed as on-line in V3. For that you need to modify the gateway configuration on the gateway so it points to V3.
However no traffic from a V3 gateway will be forwarded to V2 where V2 gateway traffic (at least join requests and traffic for nodes joined to V3 or with V3 ABP addresses) will be forwarded to V3.

Traffic for V2 ABP devices will not be forwarded to V3 by V2 gateways.


Referring to the announcement The Things Network upgrade to V3. Only EU region users need to do the migration as this is the only cluster they have deployed so far. I am in the Asia region so I can still use TTN V2 for now. It was my bad for not carefully read the announcement and made the unnecessary migration. :sweat_smile:

AU1 & NAM1 live too now… on soft launch/maintenance mode…Asia coming…

Hey there again, I’ve been trying for couple of days but still not succeeded. I migrated my application to v3(by creating a new application but using the same network session and app keys) however still can not see any data on either v2 or v3. I am using ABP instead of OTAA. Could this be the reason of my problem? The other interesting fact is that I can see gateway traffic on V2. Till 2 weeks ago, I was getting my data perfectly on TTN v2 application console however since then I’ve been having troubles for some reason.

ABP traffic from V2 gateways with V2 device addresses does not get routed to V3. Are you using a V3 device address or reusing the V2 one?

I am using V2 device address. Okay then I think I must configure my application as OTAA but I just realized that there is no Cayenne integration appears after I click ‘add integration’. Which other platform you recommend me to use so that I would be able to observe my data on a console.

My gateway says “disconnected” but when I send data with my node, it clearly sees the data and sends in to my Node-Red dashboard. But now I am in Tanzania, it seems to have connection, in the website of the gateway, but no data is received in the Things console. And it states “disconnected”. I am not sure what I need to do now.

Same problem here,
migrated my gateway from V2 to V3.

V3 console says my gateway is offline,
V2 console tells me my gateway is V3 online

In the end device live-data i can confirm receiving data through the gateway. So i think something is wrong on TTN side

Any workaround about this? One month ago I managed to migrate a gateway from v2 to v3 with success but today I did exactly the same steps for a few more gateways and I still don’t see them as ‘active’ in V3 console (in v2 they are still ‘connected’).

It can take from minutes to several hours for status to update in the consoles - it was easier to see V2 status before the live traffic was turned off/depricated…now you have to wait for the back end systems to scrape data for updates again… give it a bit of time and report back if still a problem… I moved a gw yesterday and it took approx 12 mins to appear live in V3 (I think having reguar local node traffic helped show status) but a couple of hours before V2 changed from Connected to Unknown(V2) status… similarly one I moved on Friday last took an hour or two to stablise in V3 due to local corp network issues and approx 3 hrs to disappear from v2…both now seeing regular 30 sec status update messages from GW in V3 console :slight_smile:

A post was merged into an existing topic: The Things Network V2 is Permanently Shutting Down (scheduled)