GlobalSat LT-100E


(Cramer) #1

I'm new to ttn, I hae a multitech gateway here, which is registerea and seams to work (I see it online in the console)
As a test node I have a GlobalSat LT-100E but I'm unable to get it activated. Can anyone probably help me get into the right direction?


(Cramer) #2

After some more reading I found out that I need a way to set appEui and appKey on the device. Correct?
I also managed to connect to the device over usb (serial emulation) and I see status information comming from the device, bit have not found a way yet to configure something.


(Akshay) #3

I have been having similar issue. Do you know what app EUI and app Key are needed to configure MultiTech Conduit ?


#4

The MultiTech Conduit is a gateway. Gateways do not require any keys.


(Cramer) #5

I got it all working ... Get Coordinates from the LT-100 via my and 3 other Gateways.
The Documentation and Software you get from GlobalSat is not very complete and easy readable.


(Akshay) #6

Hi Cramer,

If you can explain me details how you got working then it will be great help from you . How to get coordinates from LT-100 ?
After getting the coordinates what configuration require in conduit ?

Your help would be great.

Thanks.


(Netro) #7

Yeah, would be awesome if you can provide us with the instructions... since as you say the documentation from GlobalSat is incomplete. Thanks


(Gianni855) #8

Hello everyone,
I too have the same problem with LT-100E I should connect to and send from the gateway multitech conduit. Has anyone solved? How you configure the LT-100E device? I see it in a serial either 9600 or 115200, but I use commands? I can use AT commands?
Thank you


(Cramer) #9

You need the special Config tools from Globalsat to configure the device. Please contact your sales person to obtain them. I could not get it to work with a simple serial terminal, as some of the stuff is not relay publicly documented.


(Mdeprado) #10

Like @cramer has said, you need a special tools from globalsat, LoraConfig_S-0PC-31-1611091, this tool allows to filter the information received from the device and allow the use of AT commands, and then you can use another tool they provide or a serial terminal, in my case I'm using realtek to send AT commands to the device.
With the commands i have configured the otaa join Mode and has made a join against a multitech conduit, that is the only test i have made.

One question for those of you who have the device, have you been able to use the commands with the DEV prefix? I don't receive any response when i use them.
On another note, i have been unable to read the configuration from the device with the configuration tool, so i haven't tried to change that configuration.


#11

Hi cramer,

we are also interested in the LT100 tracker loraWAN node. You have bought it already. Could you inform me about the website where you have purchased it ?
The integration with Cayenne looks very promising for our use case in Belgium/Europe.
Tnx for replying already.

@Mdeprado : the same question for you, where did you buy it as it looks like you also found a solution to make it connect to TTN. Tnx also.


(Mdeprado) #12

@wdebbaut: In my case, we bought it directly from the manufacturer (Globalsat), but I found it initially in this website, https://market.thingpark.com/lt-100e-lorawan-compliant-gps-tracker.html.


(On8 Sd) #13

Is there a way to download the LoraConfig-tool somewhere? Google did'nt help me :frowning:


#14

I can not help you @ON8SD,

The reason is I still have not received the tracker, though already ordered a week ago at ThingPark.
I assume when you send them a request that they will hand it over to you for the price they charged you...

73s de on3zoe


(On8 Sd) #15

TNX. I received it 2 days ago after a 10 days delay so no hurry :wink:.
I've send them a request by "contact seller" yesterday. When I receive a solution, I'll post it here. In the mean time there is really nothing I can do with my new toy :-/


(On8 Sd) #16

I got a quick response from the seller with drivers, software for configuration and some extra PDF-information. In a few minutes I got it all up and running so now the status-messages are flying over all my screen :-).
So far so good only one problem left: tab "LoRaWan" seems to have only the read-only fields so no way to configure the settings for now. I'll contact the reseller again and I'm hopefull there will be a quick response again.

I'll keep you updated!


(Mdeprado) #17

To configure the LoraWAN parameters like the address, appEui, devEui, AppSkey,... you have to connect to the device with a Serial Terminal software. The developers recommend using the Realterm Software.

I have connected with it without issue, you have to use one of the software they send to load a configuration that filters the output through the serial interface or you will be receiveing data constantly and it is a little bit annoying. Then you can use a serial terminal software and you will only receive data when you enter a command or it sends something.

If you don't use the software you still will be able to comunicate with it using the serial terminal but you will received data constantly, like i said.


(On8 Sd) #18

TNX!
That means you have a list of commands available to program those settings?


(Mdeprado) #19

Yes, you have AT commands that are used with the globalsat devices.
GlobalSat - AT Commands for sensor node_V0.1_20161031.pdf (184.4 KB)


(On8 Sd) #20

Yes! We're getting somewhere :-).
Settings changed, saved, reset the device and his trying to join... Only I keep on receiving JOIN_NOT_ACCEPT now.

I only had to change JoinMode=1, AppEui and AppKey I guess?