Has anyone tried the RisingHF gateway boards?


(Chris) #22

@jmarcelino That did the trick! I reset both boards after connecting the grounds together and was able to successfully start the concentrator.

Thanks for the help!

If anyone else follows the diagram posted above and the install script from the ic880a tutorial, the change for the reset pin is located here https://github.com/ttn-zh/ic880a-gateway/blob/spi/start.sh#L4 and should be updated to 7 or your setup if it is different from the diagram.


#23

Not having any luck here... keep running into the dreaded:

ERROR: Version of calibration firmware not expected, actual:226 expected:2
ERROR: [main] failed to start the concentrator

if I enable debug I see this:

Note: SPI burst write success
Note: SPI read success
Note: SPI write success
Note: SPI read success
Note: SPI write success
Note: SPI write success
Note: SPI read success
Note: SPI write success
Note: SPI write success
Note: SPI write success
Note: SPI read success
ERROR: Version of calibration firmware not expected, actual:226 expected:2
ERROR: [main] failed to start the concentrator

I'm using an Odroid C1 which has a 40pin rPi header and I'm using GPIO 102(40-18) which I verified does toggle when the start.sh script uses 102 instead of 25 for the pin number.

I've also tried 500000 SPI speed, 50000 speed, and even 1000000 besides the default 800KHz SPI speed. It does look like SPI is working(see above debug msg) but since I have my boards connected with 6" jumper wires I was concerned.

The latest thing I tried was pulling the concentrator 5v wires from the 40 pin and providing 5v/gnd from an external power supply. It's not even pulling 100mA so I can't see how that would help since the ODroid is powered from a wall wart 5v 2A...

my global_config and local_conf are from my working Multitech MTAC system so I know they work with that concentrator and 915MHz.

Any suggestions?


#24

You need to change the global_conf.json, for RisingHF the clock source should be set to 1. For MTAC it is set to 0.


#25

UPDATE: its' working.... I forgot to look for background poly_pkt_fwd processes in the background and stop them. Once done, and with the clk set 1, it's up and running. Don't know how I missed this last time I checked using clk=1 but there it is.

UPDATE: it's working and far more reliably now that I moved the SPI clock jumper out of the ribbon cable of the other signals. I also say only 400mA used so moved 5V and gnd back being sourced from the 40pin header(5V=40-4 GND=40-6 ).


(Jose Marcelino) #26

We tried the Pibow Coupé case on one of our Raspberry Pi + RisingHF boards w/ the official adapter and hey it works pretty well!


#27

@jmarcelino, Looks good but I'm going to dig into KiCAD and generate an adapter for either connectors or direct solder of one or both concentrator and/or controller and should cost ~$5 from DirtyPCBs. Once I moved my SPI clock line my octopus setup has been running all day without a single restart of the packet forwarder process. And soon it'll be 10m in the air powered via Adafruit Power over Ethernet hack/connectors.


(Tikiarya) #28

Friends, i need some guidance.
I have risinghf RHF2S001 and i was trying to install the standard loriot connection. I have followed all the instruction, different power supply for concentrator and combining the ground.

The output of: sudo ./loriot-gw -i wlan1 -f

[2017-03-29 15:59:18.707][INFO ] Starting LoRa Concentrator
[2017-03-29 15:59:19.424][ERROR] lgw_start failed
[2017-03-29 15:59:19.424][ERROR] You might be running an incompatible version of the binary
STOP
[2017-03-29 15:59:19.425][LOG ] Concentrator stopped


I have spent a lot time but could not make it work but failed.where as lora_pkt_fwd command works.
The other image (commandline/shell) type provided by risinghf works but i need a regular desktop interface. I but i am keen on setting TTN setup.

Can i install TTN version of lora_gateway and packet_forwarder and make it work with risinghf gateway. I could see additional commands/packages in TTN repository(https://github.com/TheThingsNetwork/lora_gateway) and https://github.com/TheThingsNetwork/packet_forwarder).
Could anyone help...


(Jose Marcelino) #29

You can do the setup from https://github.com/ttn-zh/ic880a-gateway/tree/spi then edit /opt/ttn-gateway/bin/start.sh

Change the line which says

SX1301_RESET_BCM_PIN=25

to

SX1301_RESET_BCM_PIN=7


(Jose Marcelino) #30

The Resin.io setup works very well too, follow

https://github.com/rayozzie/ttn-resin-gateway-rpi and set GW_TYPE to risinghf


(Arturgontijo) #31

Hi,

What was the greatest range that you achieved? Between gateway and nodes?

Whith the HopeRF evaluation boards I got around 9km (between 2 nodes).

But the gateway receive pakets only when the evaluation board (node) is 100m far.


(Jose Marcelino) #32

5 Kms without a problem, other members have reached 15..

Something's not right with your setup.


(Tikiarya) #33

We have reached around 8.5 KM


The setup was RisingHF concentrator module RHF0M301(updated global json for TTN setup) and the node is Lora1276F30
(500 mW from nicerf ,http://nicerf.com/product_146_135.html). the Node was controlled by arduino code running LMIC.
The range could be more as we have used 4 dB whip antenna. A 8-10 dB filber glass antenna perhaps could cross 10 KM range.


(Arturgontijo) #34

868MHz or 915MHz?

What about radio power (dBm) and SF?


(Tikiarya) #35

In India it is 865-867 Mhz, node power is 500 mW, Gateway power is 100 mW,SF is 7


(Arturgontijo) #36

Ok.
Thank you!


(Networthings) #37

Some help please!

I have the RisingHF board attached to an RPI 3 following the diagram posted above. I have double checked all connections. SPI interface is enabled on the RPI.

The RisingHF concentrator is powered externally and ground pins on the concentrator and RPI are connected together.

I have used the set up from https://github.com/ttn-zh/ic880a-gateway/ using the SPI branch and have changed start.sh to set the reset pin to 7, as pointed out above.

I keep getting the following error when executing start.sh:

INFO: [main] Starting the concentrator
ERROR: Version of calibration firmware not expected, actual:0 expected:2
ERROR: [main] failed to start the concentrator

Any idea what the problem might be?

I also tried to run the utility program util_spi_stress, which gives the following error:

INFO: Starting LoRa concentrator SPI stress-test number 1
Cycle 0 > error during the 1th iteration: write 0x67, read 0x00
Repeat read of target register: 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00

Thank you!


(Arturgontijo) #38

What is the output of the command:
$ ls /dev/spi*


(Networthings) #39

Here it is:

/dev/spidev0.0 /dev/spidev0.1


(Arturgontijo) #40

Good, the SPI is working!

Some questions:
1 - What is your linux setup? Are you using raspbian? "$ uname -a" may help.

2 - Maybe the error is with the setup. Have you tried the RisingHF codes (from the manual)?
Test with their codes and see if the concentrator start correctly.


(Networthings) #41
  1. I am running Raspbian Jessie:

Linux 4.4.50-v7+ #970 SMP Mon Feb 20 19:18:29 GMT 2017 armv7l GNU/Linux

  1. Same error with both Semtech and RisingHF code.

When I run test_loragw_reg in the libloragw, I see several MISMATCHES:

Beginning of test for loragw_reg.c
Start of register verification
+++MATCH+++ reg number 0 read: 0 (0) default: 0 (0)
+++MATCH+++ reg number 1 read: 0 (0) default: 0 (0)
+++MATCH+++ reg number 2 read: 103 (67) default: 103 (67)
+++MATCH+++ reg number 3 read: 0 (0) default: 0 (0)

MISMATCH### reg number 4 read: 144 (90) default: 0 (0)

+++MATCH+++ reg number 5 read: 0 (0) default: 0 (0)
+++MATCH+++ reg number 6 read: 0 (0) default: 0 (0)
+++MATCH+++ reg number 7 read: 0 (0) default: 0 (0)

MISMATCH### reg number 8 read: 2 (2) default: 0 (0)

+++MATCH+++ reg number 9 read: 0 (0) default: 0 (0)

MISMATCH### reg number 10 read: 42 (2a) default: 0 (0)

....

Any idea?