Has anyone tried the RisingHF gateway boards?


(Arturgontijo) #42

This raspbian is the full version or the lite one?
Have you tried to use the "install.sh" from ic880a-gateway folder?


(Networthings) #43

Full version of Raspbian, I guess.

I used the install.sh from the ttn-zh repo, and same error!


(Arturgontijo) #44

That's weird...
Are you using wires to connect RisingHF Gateway to RPi 3 or do you have the adapter board?
If you are using wires (jumpers), check the connection with a multimeter.

Another thing, all the GND pins (5 total) are connected to some GND of RPi3?
And both VCC pins (2 total), are connected to your external power supply (5V 700mA min)?


(Networthings) #45

I am connecting them using jumper wires. Will test for proper connection...

Really? I thought all GND's (and VCC's) are internally connected. This is what I have:
- External power source: connected to one VCC and one GND pin on the concentrator
- Another GND pin on the concentrator connected to a GND pin on the RPI

So, this is not correct?


(Arturgontijo) #46

Now I'm using the adapter board, but at the beginning I used wires too.

I remember that when I've "forced" (connect them) all the GNDs and VCCs pins with the correct pins (GND from RPi and VCC from external power supply), the gateway started to work with more stability. Maybe this can help you.


(Gonzalo Casas) #47

Changing the reset pin is only important if you use the adapter board (because the pin is routed there), but you are jumper wiring it; are you sure that it's now connected to the correct pin in the RPi? Keep in mind that 7 is the BCM numbering scheme, so, that means, physical pin 26.


(Networthings) #48

Its is working now... but intermittently...

If anyone else has this problem: I re-did the wiring. I had checked the connections a gazillion times, and everything seemed in proper order. I decided to re-do the wiring and this time separated the jumper wires from each other.

After a restart, the gateway worked for about half an hour and then stopped with the following message:

ERROR: [main] unintended SX1301 reset detected, terminating packet forwarder.

Not sure what this one is!


(Arturgontijo) #49

Interference maybe?

Here I got this error sometimes (2-3 times a day).
But the ttn-gateway service just restarts and everything goes fine.


(Networthings) #50

I seem to get this error every half an hour or so... Well, at least it works now.
Thanks for the help.


(Gonzalo Casas) #51

The error means interference. It's caused by using jumper wires. You can improve a bit with shielded wires but best is to get a proper adaptor board.

The services restart automatically when this error is detected.


(Tikiarya) #54

from where you have received HOPERF evaluation board


(Xenek) #55

fyi, I purchased my RisingHF equipment ( iot discovery pack & additional gateway ) from IOT Australasia.

Also, hope RF and Rising HF are two different companies.


(Arturgontijo) #56

From a reseller here in Brazil.


(Thiagorod) #58

I´m having issues with RHF0M301 board (gateway from RisingHF). I follow all the instructions from them to setup the gateway using a Raspberry PI 3 and in the end I get the message "CONCENTRATOR UNCONNETED". I´m using a daughter board I designed, and already checked pin-to-pin connections and they are ok. External power supply. Any ideias?

Regards,

pi@raspberrypi:~ $ mkdir ~/risinghf
pi@raspberrypi:~ $ cd ~/risinghf
pi@raspberrypi:~/risinghf $ git clone https://github.com/Lora-net/lora_gateway.git
Cloning into 'lora_gateway'...

pi@raspberrypi:~/risinghf $ git clone https://github.com/Lora-net/packet_forwarder.git
Cloning into 'packet_forwarder'...
remote: Counting objects: 387, done.

pi@raspberrypi:~/risinghf $ mkdir -p lora_gateway/util_spectral_scan/obj
pi@raspberrypi:~/risinghf $ cd ~/risinghf/lora_gateway && make
make all -e -C libloragw
make[1]: Entering directory '/home/pi/risinghf/lora_gateway/libloragw'

pi@raspberrypi:~ $ ls /dev/spi*
/dev/spidev0.0 /dev/spidev0.1

pi@raspberrypi:~/risinghf/lora_gateway $ sudo ./reset_lgw.sh start
Accessing concentrator reset pin through GPIO7...

pi@raspberrypi:~/risinghf/lora_gateway $

~/risinghf/lora_gateway/libloragw/test_loragw_reg

Beginning of test for loragw_reg.c
ERROR: CONCENTRATOR UNCONNECTED
IMPLICIT_PAYLOAD_LENGHT = 0 (should be 197)
FRAME_SYNCH_PEAK2_POS = 0 (should be 11)
PREAMBLE_SYMB1_NB = 0 (should be 49253)
ADJUST_MODEM_START_OFFSET_SF12_RDX4 = 0 (should be 3173)
IF_FREQ_1 = 0 (should be -1947)
End of test for loragw_reg.c


(Jim Roche) #59

Double check your wiring...I also have the risingHF concentrator and the silkscreen on the board do not match the color documentation..they are upside down and backwards so just be sure it matches.

Just to be clear...the silkscreen is correct on the risingHF board but mine did not match the documentation. Just be careful your risingHF pins matches the destination mapping to the RPi pins.


(Thiagorod) #60

Hello,

I designed my daughter board following the schematics below.
Which part you mentioned is wrong? Apparently, the Raspberry PI matches with the official pinout.

It might be a problem with the RisingHF board pinout?


(Jim Roche) #61

The raspberry pi pinout is correct. The RisingHF pinout you need to verify from the silkscreen pin 1 and wire from there. I'm away but will send you a picture of my wiring thursday.


(Thiagorod) #62

Great , thanks.

This is the board I designed... the diode is not populated and the power supply (5V) provides for both RPI and concentrator. You can see the pinout connections.


(Jose Marcelino) #63

You have no Ground (GND) connection from the Pi to the RisingHF?


(Thiagorod) #64

Sorry, I removed to make the picture look better. Actually, there is a common ground plane for both (in blue), since I´m using a single power supply.