Hciuart.service does not exist

I’m getting this error:
Failed to disable unit: Unit file hciuart.service does not exist.
see image. I cant figure out how to fix this. Anybody??

Screenshot (22)

Please do not hijack other totally unrelated topics for your questions.

Which instructions did you use to create the gateway? Where did you get the image? What hardware are you using? (Model concentrator card, RPi model)

Looking at screen would shot hazard a guess at Orange Pi vs Raspberry! :wink:

@westcoastvillian please do not post screen shots where content can be posted as text & use </> tool.

My apologies for the hijacking. I couldn’t figure out how to make a new post. Its an Orange Pi 3Band Debian 12.

I have the Rak5146 with an SPI connection. The pihat is the Rak2247. The guide I used is “Quick Start Guide for Raspberry Pi and RAK LPWAN Concentrators” from Rak Wireless.

I’ve seen in other forums that this has happened to others but there is never a solution.

What do these other forums say the hciuart.service is for?

Because that will speak to how important, or not, the error message might or might not be!

New posts are only possible for users that spend some time on the forum to ward of spammers and newbies asking questions without searching for answers first.

You are trying to use installation instructions for a raspberry pi which has a slightly different OS on different hardware and OS. That is bound to cause some issues when interfacing with hardware.

The service the script tries to disable doesn’t exist on your hardware, however it is not critical for a gateway and that error could be ignored if the script would carry on. It looks like it doesn’t so you will need to either start modifying the installation script or perform the remaining steps by executing the commands yourself. Both require at least basic Linux knowledge, if you’re not up to that level may-be a friend can help? I would be surprised if this is the only things that needs fixing and doing that on the forum is going to be a lengthy process if we manage to get to a successful completion at all.

It’s something to do with Bluetooth and I’m assuming thats why Rak gateway software is not installing. I cant open gateway-config. I tried installing bluez but nothing changed. I’ve also tried putting different linux distros but I can only get Debian 12 to work.

The installer is looking to turn off the Bluetooth service so it can access the serial port for the GPS that is of no real practical use.

If you aren’t going to use a Raspberry Pi, you have a number of choices:

  1. Hack the installer
  2. Install an imaginary service for it to turn off
  3. Compile from source - I use @kersings MP forwarder

All three require a certain degree of familiarity with under-the-bonnet on Linux & hardware.