I cannot delete a device

Hello, I cannot delete a device, I changed the server address in device configuration and now I cannot access the device, it is unable to make any configuration on this, The message is:
" This end device is registered on a different cluster (insta1.nam1.cloud.thethings.industries ). To access this device, use the console of the cluster that this end device was registered on."
We also tried to delete the device with CLI and we got this message: " Registered Network Server address of end device “eui-etc” does not match CLI configuration

Have you tried this?

The application is in “nam1” cluster, and I can not choose the device for eliminating it.
I changed in device link address to “eu1”, “eu2”, “au1” and it did not work.

I have a similar problem. my application is registered on one cluster (eu1.cloud) and end-devices are registered on another cluster (eu2.cloud). There is no options to delete end-devices from different cloud. I am watching this post for any help please!