Id already taken

Hello, I have registered my devices on ttn V2 with a gateway.
I have a new gateway that I have registered on ttn V3 and I would like to read my devices which are already registered on V2 but ttn notes me: id already taken

Can you clarify what this means - are you trying to enter new information in to a page, if so, which & what? Or login? Or re-register?

If you are setting up an application to enter your devices, then you have to create an application id that is unique to all the TTN users, see:

Gday @descartes Mr Nick, I have a problem.

I have deleted my gateway for reconfigure it,but now I have this problem

I can fix it?
Thank you

id already taken

Yes, simply use another name. For instance append a number like 1.

Did you look at the documentation I linked to?

I have tried this, but there is always the same error

Now I read it!

Yep, I should have said use another ID! (Or you could read the error message)

is it possible to change id to my gateway ??

What have you tried?

You have the same documentation as we do, so we’ll be guided by your reading & research.

I completely deleted my gateway and tried to enter it again, but it doesn’t accept it

Bit sparse on detail here - what makes you say ‘it doesn’t accept it’?

Sorry, let me explain better.
I no longer have my gateway in my console.
When I go to enter the gateway again, I always get the same error.
I also try to enter my gateway with the old name, but probably I had entered the name differently and now I can no longer enter my gateway.

Is it possible to delete my gateway from the database to be able to insert it?

What error - it could be any number of messages that you are getting - DETAIL! What are you entering, what is the error message. Do NOT use a screen shot, just copy & paste it over.

What does it say in the documentation?

in the documentation it is written:

  • When a gateway is deleted, the ID is retained but the gateway EUI can be reused
  • When an end device is deleted, the ID and EUI are released and can be reused

Error is:

  "code": 6,
  "message": "error:pkg/identityserver/store:id_taken (ID already taken)",
  "details": [
      "@type": "",
      "namespace": "pkg/identityserver/store",
      "name": "id_taken",
      "message_format": "ID already taken",
      "correlation_id": "4aa4774cc8f44e148db91ee61e57a7be",
      "code": 6
  "request_details": {
    "url": "/users/iotdev/gateways",
    "method": "post",
    "stack_component": "is"

Could you spend 10 minutes on reading and understanding the documentation and related forum posts so we can spend our time reading and answering questions from people that do their homework?
Sorry if this is blunt but you keep asking questions that are addressed in the documentation or have previously been answered on the forum.

So you have all the answers then, you can’t reuse an ID that’s already in the database and the unformatted error message you posted says it’s already taken. So use a different ID.

You didn’t tell us what you were entering - as there is a blacklist of IDs you may be hitting but we can’t tell because of the lack of detail.

Why do you make this so hard on the volunteers trying to help you?

I apologize again, I do not want to waste anyone’s time, I have read the documentation, but probably it is I who did not understand.
I probably didn’t understand, we’re not all good at everything.
I’m sorry if you’re wasting time, but I don’t want to waste any of the volunteers’ time.
I am try to readd my RAKWireless 7244 LTE gateway again.
I try to find a solution by myself, if possible, thanks all for time.

Surely that can’t run to just answering direct questions??

It’s got nothing to do with reading the gateway manual and everything to do with reading the TTS manual.

You’ve read that you can NOT reuse the same gateway ID again - which means exactly that - you can’t, ever. So stop trying that.

For some reason you still haven’t told us what the ID you are trying to use is, because, and it’s back to reading what’s been typed, you may be trying to use a word that is blocked on the system.

So, tell us what gateway ID you’d like to use, we’ll suggest a working alternative and then you can get on with things.

This has been resolved - a nomclemnture mixup between ID and EUI