IFTTT Webhook?

Hi, did someone already start with creating a webhook template for IFTTT?

Currently, this integration can’t be done with pure webhooks in V3, but the issue is on our to-do list. In the meantime, you can check the solution that uses Node-RED → IFTTT Integration | The Things Stack for LoRaWAN.

Hi, my name is Nori from Japan.

I’m trying to migrate my GWs and ENs to V3 stack. I could migrate GWs, applications
and devices. Next step is connecting them to IFTTT.

I tried the procedure you showed us in the previous post. Now I have a problem

What I want to know is :

(1)What “Base URL” I have to use?
image

Some documents says it’s a “localhost”, or “public address”. I’m new for Node-RED.
So I don’t know what it is.

I tried to define my flow in the Node-RED. When I defined my flow I accessed to
http://127.0.0.1”. But my webhook doesn’t activate the flow. I’ don’t know why.

Do I have to store the definition, or a service, somewhere in a shared area, or V3
stack storage? Some document says we can store it in a GCP, Google Cloud Platform.
But I don’t think we should do that.

Thank you,

Nobody knows …

By following V3 stack procedure we can do that?

https://www.thethingsindustries.com/docs/integrations/ifttt/tts-setup/

I don’t think so. If I can not realize the “IFTTT Maker” integration which is realized
in V2 or equivalent, I can not migrate to V3.

What’s wrong on my procedure?

Which server do you think http://127.0.0.1 is sending data to?

I don’t understand what you mean. V3 procedure never tells “server”.

You entered that address in to the WebHook and you took a screen shot of it and then put a red eclipse around it and then uploaded it to your post.

So, why enter that address?

???

As I mentioned above V3 procedure says so.
I just followed the procedure.

I don’t understand your question.

Have you tried the procedure and realized it?

Maybe you should read the WebHook documentation listed at the top of the article.

And think about what happens when you enter a web address in to a browser.

And find out what the web address you have entered goes to.

What do you mean with “a web address”?

Have you tried the procedure and realized it? No?

When you access a website you type in a web address in to your browser.

That’s what I mean.

Access denied.

Have you tried the procedure and realized it? No?

Access to what?

Browser say can not reach.
And my IFTTT applets was not activated.

Have you tried the procedure and realized it? No?

The url should point to your node-red instance which should be reachable from the internet. Do you have node-red running somewhere?

I know a bit about WebHooks. Here is my presentation on Getting started with WebHooks from The Things Conference at the end of last month:

1 Like

Thanks!

That’ what I want to know.

(1)What is “your node-red instance”?
(2)What is the instance “reachable from the internet”?
(3)What does the “have node-red running somewhere”?

Good explanation document will be welcomed.

Thank you

Or use MQTT in Node-Red if it’s not reachable from the internet-at-large.

Hi, descartes

What URL did you put in your movie?
I can not read it.

And what is it?

And please advise me complete procedure to realize on V3 stack.

Good explanation document will be welcomed.

I put in the web address of the web server that I have the WebHook running on.

It’s my web server, so the address is for my systems. You need to figure out what the address of your Node-Red server is.

Samples available here: