Imposible to get Data from LSE01

Hello everyone¡ Im a student how bougth a Dragino Lse01 Soil Tester and a LG01P Gateway. I`ve got connect the Gateway in the TTN page and its seems to be fine, i have request, the problem is… When i try to connect the soil measurer, it do nothing.

I tried two ways, automaticly and manually. To make sure all the data are correct un LSE01 i did a ttl connexion, and i get the AppEUI, DevEUI, AppKey. Also i have updated the device to the 1.1.4 firmware version.

But when i create the aplication in ttn it says, “Not activity yet”.

please, someone can bring me some light??

All i read on the forums its according whith what im doing, other thing i thougth is the Sensor its broken…

Thanks for your help¡

Welcome to the forum, unfortunatly;

The LG01 and LG02 devices are not supported for use as gateways on TTN.

1 Like

Hi everyone! I am not able to find any topic closer to my problem with LSE01, hence posting here.

I have LSE01 and LPS8 Gateway. I am trying to connect them. I am very new to this.
I am following the docs. But now when I try to add end node to gateway, it is asking for AppKey. My device didn’t get a sticker mentioned in the docs. I got a sticker which only had Dev EUI and ID. How shall I proceed with it? Any help is appreciated. If you need any more info to understand the problem, please let me know. Thanks

All Dragino devices are shipped with a sticker with the required information either on the inside of the lid of the box or within the anti static bag of the node.

And where on the gateway are you adding the device? Because you add the device to TTN, not to a gateway.

1 Like

unnamed
These are the only details I got with the device. This doesnt have AppKey

Yes sorry you are right - adding device to TTN.
What do I do now?

Where is the box the device came in? Check the inside of the lid.

1 Like

What does the QR code provide?

1 Like

Usually just the Dev EUI…

1 Like

I have two soil moisture sensors. What happened is, carelessly, when I opened the box I threw it away. Hence lost the keys. Luckily I had second one with me and found the keys for that sensor on the inside of the lid.

Any suggestions for me to retrieve the keys for the first sensor?

Go the their website and find how to connect a serial port to the PCB. Then use the AT commands to get the information.

1 Like

Thank you! Will follow the steps.

After I started working with the other sensor which I have, I am not able to make sense of the data payload sent by the sensor to the cloud.
For example:
0D2C000000000757000010 This is the payload.
After using decoder:

{
  Bat: '0 V',
  TempC_DS18B20: '51.20 °C',
  water_SOIL: '0.00 %',
  temp_SOIL: '0.00 °C',
  conduct_SOIL: '0 uS/cm'
}

I am getting these values. Temperature 51.20 Celsius, Soil moisture 0? Something must be wrong I suppose?

We’ll never know because we don’t know what decoder you are using - copy of the decoder or link to it would allow someone to volunteer to investigate for you for free.

Or you could look at the code and debug it yourself …

1 Like

I am really sorry for my late replies. I am a student and having midterms etc. This is for my research work. Apologies.

Here is the link to the decoder I am using. I am not sure if this is correct but this is what I found online, output of which I posted in my last comment.

Any help is appreciated.

PS: I have few more question based on the answer of this, wondering if I shall create a new post or not. Asking this because I do not want to cause spam.

Thanks

That payload and that decoder gives me:

{
  "battery_voltage": {
    "comment": "LSE01 battery voltage",
    "unit": "V",
    "value": 3.372
  },
  "extra_temperature_sensor": {
    "comment": "Temperature from an extra DS18B20. Not connected by default.",
    "unit": "°C",
    "value": "0.00"
  },
  "soil_sensor": {
    "electrical_conductivity": {
      "comment": "Soil electrical conductivity (EC)",
      "unit": "uS/cm",
      "value": 0
    },
    "moisture": {
      "comment": "Volumetric soil water content",
      "unit": "%vol",
      "value": "0.00"
    },
    "temperature": {
      "comment": "Soil temperature",
      "unit": "°C",
      "value": "18.79"
    }
  }
}

It doesn’t matter where you post it, spam is spam, questions are questions. Best to keep context and use this thread if it’s related to your LSE01

1 Like

I don’t understand how is this happening. I am using the same decoder code and 0D2C000000000757000010 this as payload. Why am I getting

{
  battery_voltage: { value: 0, unit: 'V', comment: 'LSE01 battery voltage' },
  extra_temperature_sensor: {
    value: '51.20',
    unit: '°C',
    comment: 'Temperature from an extra DS18B20. Not connected by default.'
  },
  soil_sensor: {
    moisture: {
      value: '0.00',
      unit: '%vol',
      comment: 'Volumetric soil water content'
    },
    temperature: { value: '0.00', unit: '°C', comment: 'Soil temperature' },
    electrical_conductivity: {
      value: 0,
      unit: 'uS/cm',
      comment: 'Soil electrical conductivity (EC)'
    }
  }
}

This as output.

I am just doing console.log(Decoder('0D2C000000000757000010'));

Does this need to be passed in a different way?

Why? Just add it as a Payload Formatter - which is how I checked it for you!

1 Like

Oh nice. Did the same. Got it. But yeah I wonder why it did not work when I ran it in editor. Maybe payload is getting passed in a different format than what I thought. Thanks though.

My next step: Using mqtt to get real time data and push on my local machine!

I have started using storage integration to fetch the data for my sensor. Something went wrong from last few days. I am not getting the data, not even in the console.
The same curl request which returned me data few days back is now returning me an empty string. Not sure why. I would be very happy if anyone can help me out here. If you need any more information, I’d be happy to provide.

Is there still data incoming in the console? If not the empty result is to be expected as the data integration only retains data for about 24 hours.
If no data is arriving you should check if the device is still within radio reach of an active gateway (not too close to avoid distorted signals). Is it using OTAA or ABP?

Btw, providing information up front is fine, saves us the 20 question game…

No. I haven’t received any data for last 48 hours(don’t know why).

But I am trying to get the data for last week. When I ran the API call last week for the same day I got that data. 24 hours? I read that it stores it for 30 days.

Sorry, I was not entirely sure what information you would need. It’s OTAA. It won’t suddenly go out of range of gateway as both are stationary