In TTN Gateway Traffic is shown but the Application data is not shown

In TTN Gateway Traffic is shown but the Application data is not shown checked keys as i am using ABP method to join and gateway is dragino LG308,and using customised payload format…i checked by switching to cayenne packet format.then also same problem persists.

You may have checked the “Frame Counter Checks” Flag in the Settings Page of the Device and Restarted your Device. Because of this the Framecounter started from 0 again, but a higher Framecounter is expected.

1 Like

hey Schimmi,

Thanks for the reply issue got solved. In application, payload format and port no was missing in Device code was in custom mode and decoder function was empty. After coding in decoder function issue got resolved.

Are you saying the there was no code at all in the Decoder, and that stopped the raw data from showing in the application/device’s Data page too?

I cannot reproduce this; I simply see the raw (non-decoded) data in all the following error situations:

  • When the Decoder throws an unexpected error (say throws "oops")
  • When the Decoder returns something that cannot be represented as JSON (say return null)
  • When the Decoder defines some code, but does not define function Decoder(bytes, port)
  • When the Decoder is just whitespace
  • When the Decoder is empty (which, after saving, makes TTN Console show the example code, in gray, without any syntax highlighting, just like when hitting “remove decoder”)

In the screenshot below, counters 18, 19 and 20 show the results for erroneous Decoder functions:

Non-decoded data

1 Like

Oh, given your other post, it seems you changed some other settings (actually: disabled the frame counter checks), which probably “solved” this.

Note that disabling the frame counter checks should really only be done during development, and needs changes in your device to take care of the downlink counters. (@schimmi, you might want to read about that too; don’t disable that for production devices.)

1 Like

Hello everybody,
I have the exact same problem adarshd is describing.
I did enable the Storage Integration and I can see some data there if I connect to the Swagger UI


The devices (Zenner Water_Meter and Zenner Heat_Meter (C5)) do send data only once per day. SO maybe this is the reason I do not see it on the “Application-console” ?

additionally I was wondering how i can extract/decode the “raw” values.
I got some documentation from Zenner to decode the something like:
SP5: 51CD050000000000000000
Value channel 0: 0x000005CD = 1485 (unit kWh based on the SP9.3 packet)
Value channel 1: 0x00000000 = not available

So this Data is supposed to be hex values but when I look at my “RAW” data this is obviously not hex. (“UZsAAAAAAAAAAAA=”) -> This is from the Storage integration and I have not put any code in the “decoder” on the Application.

how can this be converted?

Thanks a lot for your help.

The raw data is base64-encoded. You can use any base64 decoder to change it to binary data.

You need to have the Data page open at the time the packets are received. (And even then sometimes nothing is shown, while, e.g., an MQTT client does show the incoming data. I don’t know why.)

As you have the Data Storage integration enabled you might also see recent messages that were received while the page was not open. I think that goes back only a few hours, so that might explain why you don’t see those. (But even for very recent messages this too might not show anything at times; I don’t know why.) See also Why application data is shown as historical?

1 Like

Thanks :slight_smile: It was not that easy to find the right decoder :slight_smile:

ok - Thanks a lot ! :wink:

Hi adarshd,

I am facing the same problem. I am passing the data from my node to node-red. I can receive data in Gateway’s traffic but cannot find any data in Application. Therefore, node-red cannot receive any data. Trials using simulated uplink messages are working and can show data in both the Application data page and node-red. Can you share the details how you fix it?