Kerlink Cellular backup on Belgian Service providers


(Wodec) #1

We have a Kerlink gateway with a sim from a Belgian mobile provider (proximus) and want to set up GPRS as a backup connection.
However, when we place the sim in the gateway (with the config below) we see that the gateway is restarting every 30 - 40 seconds. (patch for known bug “empty GPRS user & passw” has been applied).
ppp0 is not visible in the ifconfig and can not be started manually.

We have sent the gateway with the Belgian SIM to our Dutch supplier and they have done the same test on a Dutch mobile network and everything works correct !?

So:

  • gateway + belgian sim on belgian mobile network = NOK
  • gateway + belgian sim on dutch mobile network = OK

We have also tested other belgian service providers, but they have not been successful here either.

Where is the difference? Suggestions ?

Config / etc / sysconfig / network

GPRSAPN = internet.proximus.be
GPRSPIN =
GPRSDNS = yes
GPRSUSER = kerlink
GPRSPASSWORD = password

BEARERS_PRIORITY = “eth0, ppp0”


(Mascarpone) #2

Hi Wodec,

I have a very similar issue with with a german mobile network (eplus/alditalk). Did you find a solution to your problem in the meantime?

Regards
Uwe


(Wodec) #3

Hi Mascarpone,

issue still not solved :frowning:

We are talking now with our mobile providers.

I’ll keep you posted !


#4

Hello @mascarpone, @Wodec, I suggest you to contact Kerlink as well. As you experienced yourself, there are several types (and generations) of SIM cards provided by the mobile operators. There could be a firmware issue at the UMTS/GSM module used by the Kerlink gateway, ie. the module not able to handle properly a recently manufactured SIM card. Send an e-mail to Kerlink, they should be able to fix this problem.

I really don’t know what is this bug about, but as far as I know, on the operator side it is possible to disable the user and password authentication in such a way that the subscriber can put whatever user and password he likes, the mobile still will be able to connect. It is not mandatory to use this feature, but if it is not used and the user and password are both set to empty on the operator side, then the only way to log in will be by leaving user and password empty on the mobile side as well. Sorry, if I am writing something obvious that you already know…


#5

Can you please post the connection params section of your /knet/knetd.xml ?


#6

It’s enough to take a look at the system log to see if the modem is able to register in the network with the currently installes SIM card (and, actually, it’s enough to take a look at the LEDs).


(Wodec) #7

Hi hobo,

sorry for the delay.

please find below the config of /knet/knetd.xml

<LOCAL_DEV role=“KNONE”/>

<LOCAL_DEV workdir="/mnt/fsuser-1/"/>

<LOCAL_DEV min_space_size_percent=“5”/>

<LOCAL_DEV auto_answer=“NO”/>

<LOCAL_DEV system_monitoring=“NO”/>
<LOCAL_DEV apc_monitoring=“NO”/>
<LOCAL_DEV user_led_activity=“NO”/>
<LOCAL_DEV station_gsm_diag=“YES”/>
<LOCAL_DEV stop_timeout=“5”/>
<LOCAL_DEV fragment=“20000”/>
<LOCAL_DEV enable_serialize=“YES”/>

  • /knet/knetd.xml 1/68 1%
    <LOCAL_DEV min_space_size_percent=“5”/>

<LOCAL_DEV auto_answer=“NO”/>

<LOCAL_DEV system_monitoring=“NO”/>
<LOCAL_DEV apc_monitoring=“NO”/>
<LOCAL_DEV user_led_activity=“NO”/>
<LOCAL_DEV station_gsm_diag=“YES”/>
<LOCAL_DEV stop_timeout=“5”/>
<LOCAL_DEV fragment=“20000”/>
<LOCAL_DEV enable_serialize=“YES”/>
<LOCAL_DEV disable_rtc_sync=“NO”/>

Led status GSM1 & GSM2 = off !

Log output when applying pppd

Jun 6 14:16:09 Wirnet daemon.notice pppd[1722]: pppd 2.4.7 started by root, uid 0
Jun 6 14:16:09 Wirnet local2.info chat[1724]: send (\dAT+CGDCONT=1,“IP”,“internet.proximus.be”^M)
Jun 6 14:16:11 Wirnet local2.info chat[1724]: expect (OK)
Jun 6 14:16:14 Wirnet local2.info chat[1724]: alarm
Jun 6 14:16:14 Wirnet local2.info chat[1724]: Failed
Jun 6 14:16:14 Wirnet daemon.debug pppd[1722]: Script /usr/sbin/chat -t 3 -v -f /tmp/chatstart finished (pid 1723), status = 0x3
Jun 6 14:16:14 Wirnet daemon.err pppd[1722]: Connect script failed
Jun 6 14:16:14 Wirnet daemon.info pppd[1722]: Exit.

output when starting gprs:

[root@Wirnet_0B03099D ~]# /etc/init.d/gprs start
pppd: unrecognized option ‘/dev/gsm_ppp’
pppd version 2.4.7
Usage: pppd [ options ], where options are:
Communicate over the named device
Set the baud rate to
: Set the local and/or remote interface IP
addresses. Either one may be omitted.
asyncmap Set the desired async map to hex
auth Require authentication from peer
connect

Invoke shell command

to set up the serial line
crtscts Use hardware RTS/CTS flow control
defaultroute Add default route through interface
file Take options from file
modem Use modem control lines
mru Set MRU value to for negotiation
See pppd(8) for more options.
PPPD could not be initiated
RES_KO


#8

At the moment, surely something is wrong with you Kerlink box.

“alarm” means timeout, and taking into account that GSM leds are off, it seems that the cellular modem wasn’t initialized for some reason. This may be either HW problem or something with OS settings.

And it seems that something is wrong with knetd.xml . I see no GPRS-relates settings at all. What version of Kerlink firmware is installed on that box?

Are you absolutely sure that this gateway with existing settings and SIM worked well on Dutch cell. network? Didn’t you send just a SIM card to your Dutch friends? :slight_smile:

If I were you I’d try to reset the GW to factory defaults…


(Wodec) #9

Hi hobo,

Yes we are sure :slight_smile: We send the gateway back together with 2 SIM cards (2 Belgian providers) and they send us snapshots of the working gateway…

Yesterday we had a Debug session with Proximus, our SIM service provider. They confirmed that our SIM settings are correct and did not see any connection established.

All our gateways have firmware v3.1

We tested yesterday with 2 new out of the box gateways as well, with no succes…
We even checked the mechanical connection of the SIM contacts, the signal strength of the mobile provider, …

But like you, we start to doubt the results of our supplier. Maybe they tested our SIM on their own gateway…


#10

I usually first install a SIM taken from a regular cell phone into a gateway and try to make a voice call to that SIM’s number. Surely, GW will not answer :-), but at least you’ll be sure that everything is OK with HW.


#11

And, also, it seems that you provided only the head of your knetd.xml

Full file should look like this one:

knetd

And “connection parameters” section is that what I’d like to see…

(Picture was taken from this topic: GPRS connection Kerlink )


(Wodec) #12

OK, we are one step further…

With an M2M sim, we get the ppp0 started !

Now we have an other issue:

  • When the ppp0 interface is active we can ping to e.q. 8.8.8.8 over the -I ppp0 but the gateway is not connecting to TTN.

(Wodec) #13

update:
Our SIM service provider took a trace of the SIM communication and when Eth0 was disconnected, the gateway sends out its traffic on port 1700 to TTN (UDP and Radius).
So it seems it’s not a routing issue of the gateway…