Kerlink IoT station problems


(N 7) #1

Hey there,

I am working on a Kerlink IoT station and having troubles with it. Let me explain myself:

  • I can connect the gateway through ftp, and internet, but not via ssh;
  • It looks like (when on hyperterminal), that something goes wrong (watchdog) and then the station goes off and on every minute;
  • I am trying to find LoRaMacConfig or so (even on Github), but I can’t find and executable file;
  • I removed every file from this station and tryed to do the manip with the USB key but no .log file appeared (on the USB key).

I don’t want to show everything that annoys me, but did anyone had troubles like those ? If yes, let me please know what you did to go through it !

Thanks,
N_7


#2

If I were you I’d reset the station firmware to factory settings.


(N 7) #3

Thx for your reply, but I can even achieve to do it… how do you do it usually ? Because I think I already did it but nothing changed.


#4

To manually force the station to return to factory settings, you have to reset your station with the reset button 22 times.
Press the reset btn, release it, wait 5-10 second, repeat 22 times.


#5

Actually, the procedure is described in their wiki.


(N 7) #6

Thx for you help. Anyway, I did what you said lately and it seems that the station reseted properly. But now I can’t acces it even through SPN web, debut card, nor ssh. It refuses any connexion.
Its seems that the gateway refuses everything.


#7

Do you have the debug cable that comes with the gateway?


(N 7) #8

I do use it, but the login is refused all the time.


#9

I just set mine up a few days ago and it went fairly smoothly.

Followed the instructions on https://www.thethingsnetwork.org/docs/gateways/kerlink/setup.html and the Kerlink Wiki page.
Then updated the firmware to the latest version.
Then configured to send the packets to TTN (https://www.thethingsnetwork.org/docs/gateways/kerlink/config.html)

If you have tried the factory reset, then I’m not sure what else could be wrong. Perhaps you may need to ask Kerlink support.


(N 7) #10

All right then I’ll try to reset it one more time and go back to the beginning step by step and we’ll see.
Thx for your reply.


(N 7) #11

Just factory reseted the station. The connexion is still forbbiden. So, how do I know if I reseted properly ?


#12

Connection is forbidden through SSH? and the debug probe too?


#13

I’m assuming, you’ve read this, http://wikikerlink.fr/lora-station/lib/exe/fetch.php?media=wiki:kerlink_install_lora_iot_station_v2.7.pdf


(N 7) #14

I can’t connect it with debug tool nor ssh, and I have already seen this file.


#15

When you’re connected via debug probe, do you see any output in terminal after station reset with reset button?


(N 7) #16

When I press only one time the button, it shows quite a lot of things (just like if you were booting linux), and stops after a while to ask me ID and password. Then, I enter it, and it doesn’t stop saying that the login is wrong.


#17

You do use the factory default ID (root) and password(root), right?


(N 7) #18

Yep, it doesn’t work.
I try also admin and spnpwd and still the same.


#19

Are you sure it is updated with the ttn kerlink firmware? We had some problems as well installing it and it seemed we used a wrong usb stick type.
Maybe try again with a smaller usb stick?


(N 7) #20

Hello,

I finally solved my problem, thanks for you replies. In fact, as noob as I am, I didn’t know that when you factory reset the gateway, there ain’t no firmware anymore in it, so you needto reflash one in there.

But, now, I actually am trying to receive data from a little mote to my station (I don’t know how this one is configured but following the wiki, I just need to enter the keys), and nothing happens, looks like the can’t reach each others.

Any idea ?

Thx.