Kerlink Wirnet Istation - Trouble connecting to TNN

I am a total noob in working with Lorawan, so i might be overseeing something very obvious.

I am trying to connect a Kerlink Wirnet Istation to TTN, using this guide:
I followed the guide, but the gateway is still showing “not connected” in the console.

I used the web to install the newest packet forwarder (4.2), and i configured the PF by editing the 2 files “lorad.json” and “lorafwd.json”.

  • In loard.json, i used the frequencies from the EU-template, located in /user/etc/lorad/wiis (i hope this makes sense for you.
  • In lorafwd.json, under gwmp i changed the node to ““””, and the port for uplink and downlink to 1700.

I registred the gateway, using the EUI number of the gateway, before installing the Packet Forwarder. Is there something i am missing, or something i have done wrong?

I tried to use the “ps” command in Putty to check if the packet forwarder was running, but I am not able to conclude wether this means that it is running correctly:
1 root 1716 S init [5]
2 root 0 SW [kthreadd]
4 root 0 IW< [kworker/0:0H]
6 root 0 IW< [mm_percpu_wq]
7 root 0 SW [ksoftirqd/0]
8 root 0 IW [rcu_sched]
9 root 0 IW [rcu_bh]
10 root 0 SW [migration/0]
11 root 0 SW [cpuhp/0]
12 root 0 SW [kdevtmpfs]
13 root 0 SW [oom_reaper]
14 root 0 IW< [writeback]
15 root 0 SW [kcompactd0]
16 root 0 IW< [crypto]
17 root 0 IW< [kblockd]
19 root 0 IW< [cfg80211]
20 root 0 IW< [watchdogd]
21 root 0 SW [kswapd0]
52 root 0 SW [spi0]
53 root 0 SW [spi1]
54 root 0 IW< [ci_otg]
55 root 0 SW [irq/49-mmc0]
57 root 0 SW [mmcqd/0]
58 root 0 IW< [ipv6_addrconf]
59 root 0 SW [mmcqd/0boot0]
60 root 0 SW [mmcqd/0boot1]
61 root 0 SW [mmcqd/0rpmb]
62 root 0 SW [irq/35-imx_ther]
103 root 0 IW< [kworker/0:1H]
126 root 0 SW [jbd2/mmcblk0p1-]
127 root 0 IW< [ext4-rsv-conver]
132 root 0 SW [jbd2/mmcblk0p2-]
133 root 0 IW< [ext4-rsv-conver]
144 root 0 SW< [loop0]
149 root 0 SW [jbd2/mmcblk0p3-]
150 root 0 IW< [ext4-rsv-conver]
188 root 3416 S /sbin/udevd -d
345 root 0 IW [kworker/u2:1]
574 root 18100 S {kerosd} /usr/bin/python /usr/sbin/kerosd -p -r 600
592 root 2112 S /usr/bin/kgpsd -f /etc/kgpsd.conf
622 messageb 3100 S /usr/bin/dbus-daemon --system
631 root 39248 S python /usr/bin/kconf -b system
645 root 4684 S /usr/sbin/connmand
670 root 4008 S /usr/sbin/connman-vpnd -n
672 root 4676 S /usr/sbin/sshd
674 root 9312 S /usr/sbin/wpa_supplicant -u
686 root 1936 S /usr/sbin/atd -f
699 ntp 7276 S /usr/sbin/ntpd -u ntp:ntp -p /var/run/ -g
703 root 26684 S /usr/sbin/rsyslogd
714 avahi 3532 S avahi-daemon: running [klk-wiis-0508CA.local]
715 avahi 3532 S avahi-daemon: chroot helper
719 root 1704 S /usr/sbin/llmnrd -6 -d -i eth0
727 root 5060 S /usr/sbin/ofonod
733 root 2992 S /usr/sbin/crond -c /etc/cron/crontabs
806 root 29112 S python /usr/bin/statm -l 0x1e -b system
822 root 28380 S python /usr/bin/sysma -l 0x1e -b system
837 root 28168 S python /usr/bin/timem -l 0x1e -b system
854 root 27604 S python /usr/bin/smsma -l 0x1e -b system
865 www-data 4976 S /usr/sbin/lighttpd -f /etc/lighttpd.conf
866 www-data 80912 S {webaw} /usr/bin/python /usr/bin/webaw -b system -l 0x1e
874 root 13076 S /usr/bin/monit -c /etc/monitrc
892 root 2628 S /sbin/watchdog -t 30 /dev/watchdog
906 root 88924 S /user/sbin/lorad-wiis -s 0x560508ca -g /dev/nmea1 -vv /user/etc/lorad/lorad.json
927 root 92696 S /user/sbin/lorafwd /var/run/lora/gateway-id.toml /user/etc/lorafwd/lorafwd.toml -vv
939 root 2824 S {start_getty} /bin/sh /bin/start_getty 115200 console vt102
943 root 2760 S /sbin/getty -L 115200 console
980 root 4676 S sshd: root@pts/0
982 root 3056 S -sh
1284 root 0 IW [kworker/0:2]
1369 root 0 IW [kworker/u2:2]
1447 root 0 IW [kworker/0:0]
1507 root 4676 S sshd: root@notty
1509 root 1996 S /usr/libexec/sftp-server
1548 root 0 IW [kworker/0:1]
1606 root 2992 R ps

Can someone help me figure out, what i am missing here?

Best Regards

The web console is not showing connection status reliably at present.

If you have a device/node/mote, can you try sending a uplink and see if it arrives on the device console?

Hi Descartes

  • Thank you very much for your reply.

I just added a device “Elsys ERS-lite sensor” to TTN, using this guide:
But i cannot seem to get the sensor data, as the guide mention. I tried to simulate an uplink, and it looks like this: image

Simulating an uplink goes no where near any of your hardware - and it appears you didn’t enter any information either.

If you look at the logs, can your gateway see an actual real uplink from your Elsys sensor? This will check that the radios are at least working.

Where can i find the “logs” section to check it? Is that the Traffic section under the gateway?
I just got the sensor to work, so now it is giving data. image

I think the problem might have something to do with the registration of the gateway. According to this guide:,
I should use at “global_config.json” file for the frequency plan. I have not used that, and i am not sure how to do it.

It also talks about a packet forwarder bridge - not sure what that is.

According to a post on Slack, this was solved. I assume the OP will post their solution here as well.

I found the solution! - for those who are interested: I just removed the “#” in the lorafwd.toml file, in connection with the node, uplink and downlink. :slight_smile: