LGT-92 is not working as supposed, and all devices use identical APP EUI A000000000000102

Hey,

first of all, i’m new on all this LoRaWan Stuff and i tried my first steps.

I bought two Dragino devices, one LGT-92-Li and one LGT-92-AA (both 868 EU, i’m german)

Than i tried to connect this devices with TTN and faild…

There is no incomming data from the devices shown on TTN. Today i grabbed both devies and traveled direcly to places with installed Gateways. I diddn’t helped, still no data.

I noticed, that on the Dragino sticker inside the boxes there is on both devises the identical APP EUI: A000000000000102

This App-EUI looks much differend, to all the other AppEUI i seen bevor in the tutorials…

First question: is this maybe a broken APPEUI on the sticker? I thought, it hast to be unique?

I followed the official PDF tutorial from Dragino and this one from YT: https://www.youtube.com/watch?v=ff6D7hKrWhc

Thanks for help!

See Dragino LHT65 and network coverage (and scroll up a few posts for a solution, and complain at the manufacturer).

1 Like

I have one of these and it registered using the default values on the sticker, just make sure your application on TTN uses the same values (rather than the generated values when you create the app).

Some items I have learned:

The radius markers on TTN Maps doesn’t necessarily mean coverage.

The device won’t store its location, it will attempt to get location, then send it. If connectivity isn’t there, it forgets the location.

Data on the TTN application console disappears quickly. this is by design. Try to view the console within minutes of your test. Otherwise try adding a data integration and using the swagger UI. This will unfortunately add more complications like API authorization and payload translation.

A TTL/USB adapter is useful: they are inexpensive and tricky to set up, but you can see diagnostic messages and view full configurations.

The cables in the product box may not include a TTL or ST-LINK V2, the normal USB cable is for charging only. The 4 pin connector in the box is meant to pair with a TTL or ST-LINK V2.

In my region the TTN website indicates one frequency, but the gateway owners have adopted another (AS923). This is still a complication for me.

If you can see the device is registered (last seen/green status) but no data, it may be a payload issue.

The official docs are correct but I didn’t find them user friendly, especially for someone new to TTN and these type of devices.

Status: never seen

I take both devices with me to several places where i know, there are up/running multichannel-gateways. (<20meters). So i think, data has never been transmitted

as i understand it right, the only solution is to change the AppEUI in the device using a TTL/USB adapter? oh dear… than i have to get such an adapter first. :roll_eyes:

That’s how I understand some people have fixed it, yes. Others claim to not run into any problems with a non-unique AppEUI at all, including @quu_jeff above. (Seeing that some ran into trouble, I’d want to understand or fix that even if things were working now.)

Without access to the gateway traffic in TTN Console, it’s hard to debug. In case this is the first time you added an off-the-shelf device:

  • Did you select the proper AppEUI in the device settings too? So: add A000000000000102 to the Application, and make sure to select that option in the Device’s settings.

  • You also set the Dragino AppKey and DevEUI for the device in TTN Console, right?

You might want to link to that manual if you want people to validate that. Sorry, I’m not going to watch a video to see if there’s anything wrong in there.

Even more: you’ll need to have the TTN Console website open before the traffic is received. Using the Data Storage integration should not complicate anything, and is often helpful without using Swagger; see Why application data is shown as historical?

1 Like

Yes i did. I deleted the TTN generated one, so there is only one AppEUI.

Yes, i add both of them.

sure: www.dragino.com/downloads/downloads/LGT_92/LGT-92_LoRa_GPS_Tracker_UserManual_v1.5.5.pdf

or: LGT-92_LoRa_GPS_Tracker_UserManual_v1.5.5.pdf (2.5 MB)

Following up on my experiences with this device. When de-registering and re-registering the device and deleting/creating applications the devices eventually fail to JOIN. I’m not sure if its TTN caching old EUIs, or as @arjanvanb suggests that there are duplicate AppEUIs in the platform. Generating new values for EUIs is the most reliable way to get them working.

Remove your device from TTN then…

  • in your TTN app settings, add a new app EUI
  • add a new device in TTN: let TTN generate a Device EUI and AppKey, then select the App EUI you created in the last step
  • inspect the device you created and copy the AppKey and DeviceEUI for below

You’ll need a TTL/USB adapter for the next part

  • Connect to the device, and do a factory reset (AT+FDW)
  • Enter in the AppEUI, AppKey and DeviceEUI from the TTN values using the AT command set (note the syntax requires spaces).
  • before restart, check the values with ALT+CFG (note that APPKEY and APPSKEY are different)
  • ATZ or pin-reset the device
1 Like