Lora Technology MOTE Firmware Update Problem

Hello all,

I am using a Lora Technology Mote with RN2483 LCD version which has PIC18LF45K50 and I needed to increase the data rate and I figured I needed to do some changes in the source code. Before I did that, I connected the MOTE to a ubuntu device via a USB cable and opened up the Lora Development Utility. In the Lora Development Utility, RN2483 showed when I clicked on Find Devices button. And then there was an option in the screen saying “there is a new update for this device, do you want to upgrade the firmware?” or something like that and I clicked yes. As soon as I clicked, the console said “connection lost” and now i have the following problems:

1- In the devices part of the Lora Development Utility, RN2483 does not show whatever i do.
2- When i start the MOTE, it gets stuck in startup mode ( i figured it out from the source code) and it tells me to “ReRun the PwrTst”.

I tried to flash the firmware source code the microchip itself provided but both of my problems continue to exist. I used the precompiled hex file with MPLAB IDE and IPE to program the MOTE but it did not work.

I saw a solution and tried the Boot Load Recover option in the Lora Development Utility but it did not work either. Apparently, i needed to use it in Windows, and i did that but when i clicked “Update Firmware” the connection got lost again.

What can i do to make my MOTE work like the old times? It never asks the Joining Mode S1-ABP S2-OTAA. How can i revert my mistake?

The current situation is as seen below:
It continuously tells me to ReRun PwrTst and it cant read light sensor, and reads faulty data from the temperature sensor.

WhatsApp Image 2022-01-20 at 14.44.18
WhatsApp Image 2022-01-20 at 14.44.19 (1)
WhatsApp Image 2022-01-20 at 14.44.19
WhatsApp Image 2022-01-20 at 14.44.20 (1)