LoRaWAN port automatically set to zero value


I followed great tutorial for setting up own private handler: https://www.thethingsnetwork.org/article/setting-up-a-private-handler-connected-to-the-public-community-network
Everything seems working good except one thing - for all messages the LoRaWAN port is set to 0. I tried different devices (different IDs) and tried to send messages with different port numbers, but it’s still the same. In TTN handler (from debug console) I can see incoming messages (uplink) and the right ports. But when I am trying to use mqtt subscribers to see what is inside (or use ttnctl subscribe command), all messages have the same port - port 0. But the payload is right.

Any idea what can be wrong? If I understand it well, it should be handler who is publishing messages into mqtt broker. And if I can able to see the right messages with right ports inside handler debug console, where can this change happen?

P.S.: Downlink has no problem, I receive message with the right port.

Thanks, it was exactly what I was looking for! I didn’t notice that FPort was not converted from mac payload into uplink message.