Lost for options on connecting


(Mdverhoeven) #1

Hi Everyone,

I’ve spend all day yesterday on setting up my gateway and making my first project. Great for Sundays!

However I am stuck and do not know why. Here is what I have done taking into account I am in New Zealand and working off the 915Mhz spectrum.

  • Activated the gateway which is seen in the TTN Console and reports regularly and is visible on the map (https://www.thethingsnetwork.org/u/mdverhoeven)
  • Created an application in TTN Console, added a device, added the appropriate ID’s and the AU915 spectrum to the sketch.
  • Compiled, uploaded and ran the sketch. All seems to be perfectly in the serial monitor until

Sending: mac join otaa
Join not accepted: denied
Check your coverage, keys and backend status.

This keeps on repeating and I see no traffic activity on the Gateway, none whatsoever. I tried with both TTN Node as well as TTN Uno both with the same result. I checked, they are all on the same frequency (according to model stickers) and they all have the right handler.

Can anyone help me and point out what I am missing?


#2

you talking about a TTN gateway + TTN uno ?


(Mdverhoeven) #3

Absolutely.


#4

did you run the device info sketch on the TTN uno …

I think its a device 'key problem (if you’re gateway is working)

register
|DevEU|- LSB|
||AppEU|- LSB|
|AppKEY|- MSB|

and reset the framecounter


(Mdverhoeven) #5

I’m sorry. I don’t understand what you’re referring to.


(Mdverhoeven) #6

I ran the device info sketch on both. Even if it was just too get the device ID to register it in the application.

The frame counter is a new concept to me.

Do you mean I can not use OTAA and need to use ABP?


(Craig) #7

Do you have the Australian firmware on the Microchip RN2903 Radio/Lora Stack mounted on the UNO? I suspect you could be running the NA915 (North America) version.


(Mdverhoeven) #8

I have looked into that but…

  1. How do I find out?
  2. If I have found out and it is the wrong one, how do I change it?

(Craig) #9

Have a look at these threads:
https://www.eevblog.com/forum/blog/eevblog2-eevblog1062-the-things-network-progress-edit/

The firmware is not publicly available - you need to speak to a Microchip FAE or a TTN member.


(Mdverhoeven) #10

Thanks for your responses. So I bought a development board which contains a chip that has firmware that does not work with the accompanying gateway and there is no firmware update available?

That is unexpected. But hey I do expect some form of tinkering. After all it’s a development board.

Which still brings me to:
Do you have a name/email/phone number for any Microchip FAE or TTN Member?
If I have found that out and it is the wrong one, how do I change it?