Migration of Dragino LSE01 to V3 - How to trigger a remote rejoin?


I tried to migrate Dragino LSE01 devices from V2 to V3, but I have problems to trigger a rejoin.

  • I followed the guide and created a new V3 application and added the device with same appId/devId/appKey/deviceId to the new V3 application.
  • Then I regenerated the appKey in the V2 application for the device.
  • Now the tricky part: Triggering the rejoin of the Dragiono LSE01 remotely:

I tried to use Downlink commands and I think the " Reboot End Node" Command (04FF) should do the trick. But nothing has changed. Now I also tried to change the Uplink interval by Downlink command, but that also didn’t change the interval.

So I am here with two questions:

  • Would the reboot Downlink command (04FF) be the correct way to trigger a rejoin?
  • Are there some common config errors that prevent the device to process Downlink commands or did I do something wrong?
    => I click on the device in my V2 application. Scroll down to “Downlink” and leave “scheduling” at replace, “FPort” at 1, “confirmed” at unchecked, “payload” at bytes and add the bytes 04FF for reboot or 0100003C for changing the uplink interval.

Thank you very much for any hints at solving this problem.

I may have just experienced a similar issue.

  • I had recently setup my LSE01 on V3 (my first every device) and managed set my uplink interval to 20mins using the codes you mention (a different hexadecimal obviously).
  • I now want to change it to 4 hours so sent the applicable codes but still received an upload on the 20min interval.
  • I tried sending codes for 60seconds to help diagnose but no data came through.
  • So I tried the 04FF reboot command… got nothing and no data on the 20min interval either.
  • So now I’ve sent the 4 hour command again and am just waiting! hahaha.

I have no idea if the device is on and functioning or not but we’ll see in another hour :wink:

When I first set it up I’d got it running every 60 seconds before switching it back to 20mins.
Looks like all worked out OK after all as it updated on the 4 hour mark about half an hour ago.

So sorry, I’m not help to you other than to say I have a working version on V3. I can’t help with the leave/join aspect but I can confirm the commands you’re using work fine, including the reboot.

Best of luck and yell if you’d like to compare configs etc.

I see @ interval.
Yeah I have another instance of LSE01 sensors running on V3 which are doing fine and are also reacting to downlink commands. So I guess the V2 is the problem after all.

1 Like


  • as your device will only listen for a downlink shortly after an uplink it will earliest acknowledge your trigger for reboot after next cycle of sending ---- Class A device is not listening all the time for your commands …

  • also you selected “replace” during all of your attemps to reconfigure via downlink – this means that each downlink you send will replace the one before – for changing the send-cycle send the 0100003C for example … and wait until its downloaded to the device after another uplink

  • when this step is done - you can trigger the device for reboot with 04FF – and after another uplink in your short time intervall it should reboot your device (and join it to the v3)

1 Like

Thanks for your advice.
Yeah I didn’t grasp that downlink only after uplink concept at first, but in the meantime I did by reading some other posts. Unfortunately even after waiting for the uplink to trigger the downlink command for e.g. changing the interval does nothing on TTN V2 but works fine other sensors of the same typ connected to TTN V3.

@topocare_scholz is the device sending data at all ? – so can you see uplink-messages in the ttn v2 console ? and if this is going well - can you see your downlink message in the console too ?

Yes, it is sending data just fine every 20 minutes.

Here is a screenshot of my console after scheduling the downlink for a 1 minute interval and the next uplink.