Migration of TTIGs to The Things Stack CE (v3)

Can we please keep this thread for what it was intended? I don’t want new members coming here and asking for general TTIG debugging. There are enough threads for that.

I just bought a TTIG from RS and I am expectant to be able to use it in V3. Is there already a due date for v3.12.2 ?

v3.13.2 is scheduled for 23 June; v3.13.2 Milestone · GitHub


Hi, @KrishnaIyerEaswaran2:

Thanks a lot for the info.

And also thanks to @kersing. As he pointed out, even if the TTIG is not visible at all, the brand-new gateway was able to forward packets to the corresponding application in the V3 console. I had no issues with both uplink and downlink messages.

Good job and, again, thanks to all!


@KrishnaIyerEaswaran2 earlier you mentioned v3.12.3 is scheduled for 23 June then you mentioned v3.13.2 as git link

My console state v3.13.1


I can see already a gateway with the same EUI in v3 console but disconnected. And it seems the gateways shows connected still on v2.

You mean that the claim process on v3 will be available from v3.13.2? (or v3.12.2?)

Thanks for confirming that!


Yes, because 3.13.2 is scheduled for 23 June …


I see the confusion. I’ve fixed the version in my comment. We are in the process of internal testing. Once we are confident, we’ll deploy to the community clusters and inform users here.


6 posts were split to a new topic: Move The Things Kickstarter Gateway to V3

I’m about to register 3 new TTIG on TTN. Should I register them on the V2 console before gateway registration is disabled or should I wait a couple of days to register them directly on the V3 console?
Thanks in advance for your precious advice.

Absolutely no harm in registering it on v2 so it’s working right now.

I think we are awaiting the release of instructions on how to claim our TTIGs on v3.


Are there any news about this migration and the claiming process? Thank you in advance.

Yes, it’s working but it needs some refinement.

We’ll share an update later today/tomorrow on this along with V2 going read only. Please stay tuned.


It apparently already has - for gateway registration.

So i undestood… later today / tomorrow is equal to “tomorrow”? right?

TTI worked until after business hours to solve a (last) niggling issue so it will be tomorrow (depending on your timezone :slight_smile: )

1 Like


In the meantime i was trying the command line interface…

Claim a Gateway | The Things Stack for LoRaWAN (thethingsindustries.com)

But the docs didn’t report what you need to use as <claim-authentication-code>

And getting:

FailedPrecondition desc = error:pkg/deviceclaimingserver:gateway_not_authorized (gateway not authorized for claiming)

As, in fact did Jac & myself to help get this done.

1 Like

It’s the gateway WiFi password

Thanks @descartes, i’ve tried the wifi password printed on the gateway but still getting gateway_not_authorized

Show me the command you are using, without the password and if you are overly paranoid, change the EUI

1 Like