Mikrotik LR9 gateway and Adafruit RFM9x Hat

I have just deployed a Public LR9 gateway on TTN at my home. Is all connected and sees traffic (I think). Hard to know as there doesnt seem to be anyone in my area with TTN devices. I have purchased an Adafruit RFM95 LORA hat for a PI4 to act as a closed loop test device for monitoing that my LR9 TTN node is active.

Any advice for a newbie appreciated. I can get the Lora Hat on Pi to transmit with Adafruits tinylora example. The TTN Gateway console sees the payload and forwards it on. BUT! it never turns up in my defined application (sigh). The tinylora example uses ABP auth. I am being carefull to use sequential frame counts but to no avail.

Cant seem to see any way of diagnosing why the traffic isnt routing from the gateway to the Application queue. I am now a little lost having tried most everything i can find to resolve it.

Thanks for the read.

  1. Might not be obvious but given both node & GW at house make sure there is good seperation between them - preferably with an absorber such as a wall between them. Look to be >>3m ideally >10m away. to avoid ‘shouting’ in the receivers ears! (Good tip is make sure RSSI is < -45dbm, ideally <-50dbm for reliable consistent operation, and to reduce ‘near far’ problem with more remote nodes.

Erm, dont! (This is not recommended in V3, as stack seeks greater compliant and ‘correct’ behaviour and MAC instruction handling - search the forum and you will see why and lots of discussion!

  1. Use a well established and more mature libray such as MCCI’s LMIC instance, or others that get well rated on the forum (search is your freind once again…), such as LMIC-node | One example to rule them all

Not sure if that is setup for a Pi HAT with RFM95 - the second query for this device in two days - which just goes to show that not only is Search your freind, it is your friend too.


To make it more clear: LMIC-node is a structured cross-platform example that uses the MCCI LMIC library, but it doesn’t support Raspberry Pi because it is based on the Arduino framework.

Thanks to all who replied, have taken advice and ditched tinylora. Purchased a MKRWAN1310 today, tried to set up their example on the V3 console. Set up the Firstconfig OTA registration, LR9 sends it to the network, TTN app device console reports the “Join request” but then say “Drop join-request” “Data Rate not found”.

Eventually the TTN App console says it has forwarded the join-accept to the application server. Still very lost

Again any help appreciated.

FirstConfiguration is no such thing, it’s just a stupid bit of code that requires you to type in the AppEUI & AppsKey manually for no real benefit. It doesn’t configure anything as nothing is remembered afterwards.

Ensure you are using the v1 library that’s called “MKRWAN” and not the v2 which is sort of beta/abandonware.

The device repository config works OK except for some idiocy involving a test payload formatter that you will want to turn off once you’ve got basic comms going.

Use the example “LoraSendAndReceive” with your own settings.

If the sketch says you need to upgrade the Murata module firmware, just hold fire on that until you’ve tried the basics above.