MikroTik wAP LoRa8 not registering to TTN

Hi all!

I’m at a loss. I’ve got a brand new MikroTik wAP LoRa8 but it’s not registering to The Things Network.

I’ve set it up as follows:

  • updated the RouterOS to 6.49.7 (stable)

  • reset configuration

  • bridged all interfaces

  • set up DHCP client on the bridge to get an IP address

  • used “LoRa Device - Hardware ID” as the “Gateway EUI” to add the gateway in TTN console

  • set “LoRa Device - Gateway ID” to a unique combination of sixteen numbers

  • used “LoRa Device - Gateway ID” as the “Gateway ID” in TTN console

  • set “LoRa Device - Network Servers” to “TTN V3 (eu1)” (eu1.cloud.thethings.network), which matches “Gateway Server address” in TTN console

  • set “Channel Plan” to “EU 868”

  • enabled LoRa on MikroTik
    lora device
    (I should probably disable forwarding messages with errors)

  • tried both “Europe 863-870 MHz (SF9 for RX2 - recommended)” and “Europe 863-870 MHz (SF12 for RX2)” in TTN console

But the MikroTik keep showing as disconnected in TTN console:

Did some checks:

  • I am able to ping google.com through the terminal on the Mikrotik, so DNS is resolving

  • using torch on eth1, filtering for UDP on port 1700, I see IP addresses for TTN communicating with my MikroTik

  • I am receiving messages in the “LoRa - Traffic” tab

  • on my ISP’s router, I forwarded port 1700 (TCP+UDP) for the MikroTik, just in case

Anything I could try next? Or does anyone see an error I’ve made?

Best regards.


Your opening post rocks - very well done - normally we get so little information it takes effort to get started!

Typically the Gateway ID is actually the Gateway EUI - it’s a left over from the olden days when the first packet forwards were invented and they created an EUI from the MAC address.

So whilst I’m not a MikroTik user, I’d go with using the Gateway ID on the router web page as your EUI.

And you can make the Gateway ID on the console anything that speaks to your - like “ether-gateway-01”. You will NOT be able to use the Gateway ID you have already entered, ever.

Hi Nick, thank you for getting back to me so quickly.

Oof, after everything I’ve tried, this was indeed the problem.
Making the “Gateway ID” the same as the “Hardware ID” on the MikroTik instantly resolved the problem.

I set the “Gateway ID” to something unique because I deleted the gateway at some point, and indeed couldn’t reuse it in the console.

So really, thank you a lot!

Best regards.

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.