MQTT used to work fine, but stopped getting data

Hello everybody,
I activated mosquitto_sub via script. Approximately Two days were data, everything was good. Without having changed anything changed at one point, no more mqtt data come from ttn? In the web login of my account I can see very well that my sensor data arrive. Thanks in advance.

My code:
mosquitto_sub -h -t ‘+/devices/+/up/#’ -u ‘xxxxxxxxxxx’ -P ‘ttn-account-v2.Mxxxxxxxxxxxxxxxx’ -v >> data.txt

What happens when you restart the script? Did you check the TTN status page TTN status page and Slack #ops channel for known outages?

There are some modifications made to the up-messages today see Slack #ops channel for more info:

@htdvisser 2019-11-18 11:19 AM

After some investigation we suspect that the MQTT issues are caused by the “uplink fields” that are published to individual MQTT topics, so we’ve temporarily disabled those. Please let me know if this change improves the situation for your applications.

htdvisser 2019-11-18 5:59 PM

Normal uplink messages are published to <AppID>/devices/<DevID>/up . Uplink fields (now temporarily disabled) are published to <AppID>/devices/<DevID>/up/<Field>


Hello, I’m experiencing the same problems. Since yesterday at 10.00 a.m. there is no more data coming through my node-red connection. On the TTN console and Applications I see the data coming in from my node. The TTN Status page is not accessible.

The wrong URL was given above; fixed now. Also, I added some details from Slack to @mvdswaluw’s post.

What happened when you restarted Node-RED?

Same issue here. No data via MQTT since yesterday… Could you please share the new format of uplink messages if this has changed ?

The changes have already been documented in the quotes from Slack above. (The format has not changed, but subscriptions to /up/<some single field name> are no longer getting data.)

How are you subscribing? Also, as per @kersing’s suggestion: did you try to restart whatever software you’re using to subscribe to the MQTT data?

Restarting Node-Red did not solve the problem.

And (as asked as well) how are you subscribing? What is the subscription string?

My solution:
mosquitto_sub -h -t ‘+/devices/+/#’ -u ‘draxxxxxxxxxxx’ -P ‘ttn-account-v2.lxVC4Xpxxxxxxxxxxxxx’ –v (without up)
and a lot of grep;cat and cut

@arjanvanb Thank you. I do not have an account to the Slackworkspace, is there any information what “temporarily” means? I’d need my field values back :wink: Is it planned to activate field values again or is there another way of getting them?

I restarted again (using openHAB MQTT client) - still no values by subscribing to:
<AppID>/devices/<DevID>/up/<single field>:state:default

The fields have been enabled again according to messages on slack.

Could you try with “-t ‘#’” and no grep/cat/cut just to check if data is arriving? I’ve got mosquitto_sub running using that topic for well over a year without problems (apart from some back-end downtime) and am currently receiving data.

In a Node-Red node, you don’t give a connection string. In a number of fields you give the Access Key, Device ID and the corresponding field. As with MQTT it doesn’t work if you fill in a field. An empty field gives you all the information you need. So for now the problem is clear… Must change my Node-Red.

What you need to specify depends on the Node-Red node you are using. Are you using an MQTT node or the TTN Node?

I’m using the TTN node. But with some adjustments in Node-Red the problem is solved.

Care to share those adjustments for other users who might run into the same problem?

I use Node-Red to send data from my end-node to Domoticz. In this case Temp, Humidity and Pressure. Previously TTN sent this data per field but now it spits all data at once. Previously I had to collect all the data that came in randomly and only then send it to Domoticz. Now I get the data in a fixed format and only need to convert it to the correct format for Domoticz. That’s all :slight_smile:

For Node-RED I just commented here: TTN uplink node Node-Red connected but not working

Is there a mailinglist where outages like this one are communicated? If not, there should be one…