New ATmega328 LoRa board by Elecrow

Yesterday I’ve got a new development board from elecrow.


unfortunately only DIO0 is connected to the µController. So i had to connect DIO1 pin at he RFM96 to unused pin 5 at the Atrmega328P to get the arduino lmic otaa example running. The pin mapping is

const lmic_pinmap lmic_pins = {
  .nss = 10,
  .rxtx = LMIC_UNUSED_PIN,
  .dio = {2, 5, LMIC_UNUSED_PIN},

Seems to use about 45µA in deep sleep mode - not bad :slight_smile:

To get further a schematic would be helpfull. Any hint?


Hi Andreas,

Send an email to and ask for the schematics. I did that also for the 32u4 from elecrow. This board misses also dio1.

@bvdbrule thank you for the hint. I sent an email and hope to get the schematics.

I also tried out the 32u4 boards some time ago but found that aditional to the missing DIO1 connection the i2c bus doesnt work :frowning:

Got the link to the schematics today.

Of course it’s much easier to connect DIO1 to GPIO5 by using J3 :wink:

The available infos can be found at:


Hi Andreas,

I have bought the same board. I’ve connected DO1 using J13, however I cannot get Lmic with receive to work. OTAA example would not register the device, used the ABP example and data is received in my gateway, but no data to the node. Did you do something else than defining the pins, which board type did you chose in arduino ide?

Did you copy the EUIs using LSB? See Hex, lsb or msb?

I did, lsb for APPEUI and DEVEUI and msb for the APPKEY.
It seems like it does not go into rx mode.


i have the same problem. Did have a solution?

regards michael


For me the problem was the power source. During testing I only used the programmer. Once I got the battery (which for some reason is not 18650 size) it worked. Might also be related to noise from the PC via the USB interface, I don’t know.

The flying lead antenna that comes with the board is not performing well i my case, compared to meet je stad station (using the same radio). Shall soon test with proper antenna, hopefully it will be better. It could off course be a bad board.

i found my problem. The delay command do not work in the sketch.

void loop() {
// do_send(&sendjob);
// delay(SAMPLE_INTERVAL); // Pause zwischen Messungen

I want yo connect Elecrow Radio Node V1 to MAX485. It requires digital pins and tried A0, A1, D4, SCA, SCL pins to cinnect to an Electrical Conductivity sensor with RS485 outpuy but the output from Radio Node is always FFFFFFFFFF. I can use a Nano Arduino or ESP32/lora/lilygo connected thru MAX485 and it works fine. But with Radio Node Atmega328P it wont. Has anyone tried max485 with elecrow? I will be glab if you can helo.