No data transfer to sensor node in V3

Just to be clear:

You’ve got a gateway on v2 and a device on ABP on v3?

There has been some issues with the packet broker that may have impacted you.

But the key questions are:

How do you know the device is uplinking? Is there a serial port you can monitor or a button you can use to trigger an uplink?

Can you see the uplink from your device in the gateway’s log?

Can you see the uplink from your device on the gateway v2 console?

Can you see the uplink from your device on the devices v3 console?

Just to clarify:
I have a gateway on V2 and a end device (sensor node) on ABP on V3 !
In the V2 console of the gateway I see the uploads from the device!
In the V3 console of the device I see no uplinks !

Added info:
Simulating an uplink from V3 console shows:
Receive upllink data message
Forward uplink data message MAC payload BC FPort: 1 (BC being the simulated payload)

What did you use for the DevAddr when setting up the device?

Device Address: 260BBFF7

That’s a v3 DevAdr so that’s fine, I believe there is an issue with routing v2 addresses.

I’m getting a bit fuzzy with all the moving parts I’ve been testing of late. I’ll setup a test in the morning so I can see what happens.

Thanks in advance for your effort. Curious to hear what the outcome of your test is.

I setup a basic device on ABP, turned off my v3 gateway and I’m getting uplinks just fine via my v2 gateway.

I tried with an ABP device I copied over with a v2 DevAddress but that wasn’t picked up as expected.

I’ve tried a downlink to the ABP device but I’m getting “no device session; check device activation” as an error - this was working 31st Jan so not sure what’s going on there. Edits on the Network settings still don’t persist.

I think you may need to setup a device from scratch again to be really sure that something hasn’t happened to the config on the server.

I noticed that by adding a new application, the V3 console does not show the possibility for setting “Link new application to Network Server atomatically” as I saw in the youtube instruction video of the Things Network.
Could that be possible the reason of failure? I don’t know why this is not shown to me.

Don’t know where that is - can you tell me + the video.

I’d not see the need to setup a new application, but certainly a new entry

This is a printscreen of my console
afbeelding
The instruction video I am referring on is on You Tube: Creating applications and adding devices to The Things Stack - YouTube

Ha, that’s almost ancient history. No option like that on my console either - never knew it was there. Just crack on.

Except I didn’t say add a new application, so you are on your own in that respect.

What do you mean by new entry, a new end device in the same application on V3 console?

This is getting silly.

Please just create a new device to see what happens, create it in v3, I don’t care if you want to create a new application for it, it’s irrelevant AFAIK.

Creation of new device in V3 has no result. Now I have registrated a gateway in V3 and data is coming in now from the V3 sensor. I think the issue is the gateway which is a single-channel one. I understood that these gateways are not supported by TTN for transferring data from V2 to V3. Can that being confirmed ?

Just plain not supported. Period. Please disconnect this from any part of the TTN network as not only are they NOT a gateway, but they are hugely disruptive to the network - devices expect 8 channels, you have one and its presence can cause all sorts of uplink & downlink issues.

So please disconnect now.

And what does any forum search of any post /thread about single channel 'gateways, dual channel ‘gateways’ or single/dual channel packet forwarders from the last 3 days to 3 years tell you about this? Anything ‘confirming’? It is a complete waste of everyones time trying to action and debug around one of these… and you cannot clain ignorance as by your post you are aware of a problem.

Clearly, this is not the way to encourage people to step in and support and help you…use search, read the available documentation and help yourself 1st then others can make a decent fist of helping from there on, but you have to have the basics in place to avoid such time wasting.

When asking questions, always first try to search the forum for existing information. Many questions have already been previously answered.

Have a look at the the following:
Single Channel Packet Forwarders are deprecated and NOT Supported [guidelines]

I started with LORA in 2018 and then stopped until this year. Unfortunately I was not aware of the changed status of the single channel gateway. I now have read the information of oct 19 and it is clear to me. I apologize for that.
The single channel gateway is taken out of service and will be replaced by a proper one.

4 Likes

:+1: Good, thanx