No data transfer to sensor node in V3

I registered a sensor node in V3 in ABP-activation mode.
In my gateway in the V2 console I see that the payload is received by the gateway. In the V3 console however I see no data coming in and also none joinEUI.
I understood that data received by V2-gateways are automaticly transferred to V3.
Why do I see no data in the V3 console? The node has never been operated in V2, so all keys and identifiers are specific in V3.
Can anybody explain where to look for the reason of no transfer?

ABP means the DevAddr (and AppSKey & NetSkey) programmed in the device will be used. If that is not a V3 address no data will be forwarded to V3 by gateways connected to V2.
Only OTAA uses JoinEUI. OTAA is the preferred activation mode.

1 Like

There was a partial outage of PacketBroker - that handles the routing of messages from V2 GWs to V3 Apps over the last 12-24hrs - believed resolved now but only in last hour or two I think (not showing in status now) - that wont have helped…

Thanks for your responses.
DevAddr, AppSKey and NetSkey comes from V3 and ar programmed in the device. One item is missing in the V3 console: AppEUI, I don’t understand the purpose of this item. I was not able to find that in the V3 console.
The data is still not comming in the device, only the following info:

Stream reconnected

The Console was able to reconnect to the internet and resumed the event stream. Subsequent event data will be received and displayed. Note that event data which was possibly emitted during the network disruption will not be re-delivered:

Raw event

“time”: “2021-03-09T17:23:26.801Z”,
“name”: “synthetic.status.reconnected”,
“isError”: false,
“isSynthetic”: true,
“unique_id”: “synthetic.1615310606801”
For more information on event message types, please see our bookData Formatslaunch documentation.

This just an error message relating to the live console feed.

If you refresh the page it will reconnect.

Then hopefully you may over a period of time see some uplinks.

As for the AppEUI which is also called JoinEUI depending on where you look in the console, this is not required for ABP which is the connection method for the credentials you’ve used.

I am waiting now for 3 days and no data received. Is the issue the data transfer by TTN between the V2 server and the V3 server or is there anything I can try?

Just to be clear:

You’ve got a gateway on v2 and a device on ABP on v3?

There has been some issues with the packet broker that may have impacted you.

But the key questions are:

How do you know the device is uplinking? Is there a serial port you can monitor or a button you can use to trigger an uplink?

Can you see the uplink from your device in the gateway’s log?

Can you see the uplink from your device on the gateway v2 console?

Can you see the uplink from your device on the devices v3 console?

Just to clarify:
I have a gateway on V2 and a end device (sensor node) on ABP on V3 !
In the V2 console of the gateway I see the uploads from the device!
In the V3 console of the device I see no uplinks !

Added info:
Simulating an uplink from V3 console shows:
Receive upllink data message
Forward uplink data message MAC payload BC FPort: 1 (BC being the simulated payload)

What did you use for the DevAddr when setting up the device?

Device Address: 260BBFF7

That’s a v3 DevAdr so that’s fine, I believe there is an issue with routing v2 addresses.

I’m getting a bit fuzzy with all the moving parts I’ve been testing of late. I’ll setup a test in the morning so I can see what happens.

Thanks in advance for your effort. Curious to hear what the outcome of your test is.

I setup a basic device on ABP, turned off my v3 gateway and I’m getting uplinks just fine via my v2 gateway.

I tried with an ABP device I copied over with a v2 DevAddress but that wasn’t picked up as expected.

I’ve tried a downlink to the ABP device but I’m getting “no device session; check device activation” as an error - this was working 31st Jan so not sure what’s going on there. Edits on the Network settings still don’t persist.

I think you may need to setup a device from scratch again to be really sure that something hasn’t happened to the config on the server.

I noticed that by adding a new application, the V3 console does not show the possibility for setting “Link new application to Network Server atomatically” as I saw in the youtube instruction video of the Things Network.
Could that be possible the reason of failure? I don’t know why this is not shown to me.

Don’t know where that is - can you tell me + the video.

I’d not see the need to setup a new application, but certainly a new entry

This is a printscreen of my console
The instruction video I am referring on is on You Tube: Creating applications and adding devices to The Things Stack - YouTube

Ha, that’s almost ancient history. No option like that on my console either - never knew it was there. Just crack on.

Except I didn’t say add a new application, so you are on your own in that respect.

What do you mean by new entry, a new end device in the same application on V3 console?

This is getting silly.

Please just create a new device to see what happens, create it in v3, I don’t care if you want to create a new application for it, it’s irrelevant AFAIK.