No GPS in Metadata but GPS set in Location of the gateway

In the Metadata i didn’t find the lattidue and the longitude of my gateway:

{
“time”: “2019-08-22T19:48:01.067236151Z”,
“frequency”: 868.5,
“modulation”: “LORA”,
“data_rate”: “SF7BW125”,
“coding_rate”: “4/5”,
“gateways”: [
{
“gtw_id”: “eui-58a0cbfffe800dc7”,
“timestamp”: 46164651,
“time”: “1970-01-01T00:00:01.56650328Z”,
“channel”: 0,
“rssi”: -33,
“snr”: 8
}
]
}

But in the console i set these values:

image

What did i wrong?

Did you set the tick box for location information to “Make public” in gateway settings, privacy?

This are the data is see in the console:
{
“gw_id”: “eui-58a0cbfffe800dc7”,
“payload”: “QE0WASaASQAB2wjWFm3oXbGLBm9wJHi9XYvkj18=”,
“f_cnt”: 73,
“lora”: {
“spreading_factor”: 7,
“bandwidth”: 125,
“air_time”: 66816000
},
“coding_rate”: “4/5”,
“timestamp”: “2019-08-24T08:43:21.615Z”,
“rssi”: -43,
“snr”: 9.75,
“dev_addr”: “2601164D”,
“frequency”: 868300000
}

I miss this;
“latitude”: 50.18096050,
“longitude”: 9.15976224,

This are my settings:
image

In my case when I enabled fake_gps my gateway was reported without location. I removed all the references from json file about location and the console location setting was active again.

thank you for your answhere. I am new at TTN, Where can i find the json file?

What is your gateway? The TTIG? Maybe you have configured there a location? Try to disable it.

It is the TTIG. Where can i disable the location in the TTIG?

Privacy settings of the gateway in the TTN console.

Thank you for your answhere.
Is this correct?
image

Go to the settings, privacy and set location to private,

Why privat? then nobody see the location?!

And the location will not be sent in the metadata of packets… Wasn’t that what you are looking for?

I wisht that the location is in the data that are send.

I will see the gateway in ttntracker.

I have the same problem. Location ist set on the TTN console and privacy is set to public but

wget -O - http://noc.thethingsnetwork.org:8085/api/v2/gateways/eui-58a0cbfffe800f38

shows

“location”:{}

I also have the same problem. All privacy settings are pubic.

http://noc.thethingsnetwork.org:8085/api/v2/gateways/eui-58a0cbfffe80101b

timestamp “2019-09-04T16:23:58.609642718Z”
uplink “262”
downlink “262”
location {}
frequency_plan “EU_863_870”
gps {}
time “1567614238609642718”
rx_ok 262
tx_in 262

Why?

This seems to be a serious firmware bug. See my current postings.