No join accept received

Cannot join the network, No join accept

Gateway: rak7246 gateway
End device: arduino r3 + LA66 lora hat

I am facing a simliar situation like the link above, while all of my frequency plan are AS923/AS923-2. Data could pass to the gateway but couldn’t reach the Application.

I am sure there is no typo in those EUI, I directly copy them from the AT command’s results and double checked them. My photos may not show clearly but my JoinEUI and DevEUI is not same.

What could be wrong?

Gateway settings:

Gateway console:
Only have these two type of message repeating

End device:

Please let me know if more information/photo is needed.
Thanks again.

As you have a private TTI instance can you not make use of the paid support option?

Apart from API & the AppKey, pretty much everything is public data that helps with debugging, so the redactions prohibit making any cross-checks.

Have you reviewed other forum posts other than the one you linked? You don’t have a “No join accept received” issue - you have a “No join requested processed” issue. To clarify, please read the Learn materials linked at the top of this page - it will show the flow of the join sequence.

1 Like

Thank you for your reply, although I am using the private TTI but I am just using the free “Discovery” plan, I am not sure if I can make use of the paid support option.

For the data, I have removed the redactions.

Will look for more posts about “No join requested processed” and related materials.

From LoRaWAN version 1.0.4 on, the nonce used during OTAA joining should increases monotonically (since the last time). If the nonce is lower than the last received valid nonce, it will be ignored.

If your device is based on LoRaWAN version 1.0.3 (for example), it probably uses a random nonce. If the server expects / is configured for a LoRaWAN 1.0.4 device, it expects a monotonically increasing nonce instead. The nonce is only 16-bit, so with this mismatch between device and server you can very quickly run out of valid nonces.

So, check the LoRaWAN version of your device and make sure it matches the version configured for the device in the TTN console. You could try setting it to 1.0.3 in the TTN console and resetting the MAC state.

1 Like

2 observations

  1. rather than having your device hammering away trying to join every 30-40 seconds can you set up to trigger manual attempt (button push?) if not joined in a few attempts it is unlikely to join after 30 mins of hammering like a woodpecker! :slight_smile:

  2. …and likely most important RSSI value !!! (Forum search)

Your node IS SHOUTING AT THE GATEWAY…and likely due to proximity the GW IS SHOUTING BACK! Channel bleed/cross talk mitigation for the win (Forum Search: but basically get seperation and absoption such that RSSI say <-60dbm) and try again and report back…

1 Like

I have remove the code for automatically sending messages. And unpluged the device when I am not using it.
Tried to decrease RSSI to negative 69 and 93. But seems still not working.

Seems if i am using the AS923-2 plan, I am not able to use the LoRaWAN 1.0.3.
And the store page wrote it is LoRaWAN 1.0.4.

But I could see some join request if I change the frequency plan and using the LoRaWAN 1.0.3 on the Application page.


Sure you can, if you pay for it! Why go with the free Discovery plan?

You appear to be sending join requests every 30 seconds despite:

Which store? The Dragino product page & the wiki both state v1.0.3, somewhat evidenced by it working when set to v1.0.3. The code base for the LA66 has LoRaMAC-node v1.0.2 so YMMV.

Assuming the gateway console is showing the transmission of the join accept, the issue now is to get the device to hear the transmission - which is usually down to overload due to lack of separation of gateway & device.

1 Like

Thanks, I just confirmed with the store that the LA66 Sheild is lorawan v1.0.3.

So I guess now the problem is about the freqency plan.
As the [AS923-2] dont have the option for [lorawan v1.0.3] on the End devices settings,
I guess i have to use another plan like [Asia 920-923 MHz (used by TTN Australia)#] for gateway and end device,
and I would config my gateway’s [tx_freq_min] and [tx_freqmax] in [923.2] to limit the uplink freqency (prevent violation).

And when I test I will decrease the rssi and uplink interval.

I will update the result after i try.

Thanks a lots.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.