Cannot join the network, No join accept


I am currently using Dragino’s LPS8N gateway and the LA66 LoRaWAN Shield. I have already connected the gateway through TheThingsStack ( and am in the process of activating the LA66 LoRaWAN Shield as an End Device via OTA. I’m trying to activate the LA66 by connecting an Arduino Uno to the Shield and uploading the “Join-TTN-Network” code provided by Dragino to join the network. However, I’ve encountered a problem at this stage. When I check the gateway’s log, I can see that it receives the Join request packet sent by the LA66 End Device correctly, but no response occurs after that. Here’s what I’ve tried to resolve the issue, but without success:

  1. Checked for the possibility of a mismatch between the AppKey entered when registering the End Device on TheThingsStack and the AppKey confirmed through the AT command on the serial monitor of the Arduino connected to the LA66. I tried to find out the mismatch with so many times, but there was no mismatch.
  2. Packet loss due to the proximity between the gateway and the End Device. To prevent this, I placed the gateway and the End Device about 5 meters apart.
  3. Reset used DevNonces. I found a solution from another topic that suffered from a similar issue. I tried this several times, but it didn’t work.

Here is some information about my problem.

a) Arduino serial monitor log
12:55:38.188 → Dragino LA66 Device
12:55:38.221 → Image Version: v1.3
12:55:38.253 → LoRaWan Stack: DR-LWS-007
12:55:38.286 → Frequency Band: AS923
12:55:38.319 → DevEui= A8 40 41 27 51 84 E0 86
12:55:38.354 → ***** UpLinkCounter= 0 *****
12:55:38.421 → TX on freq 923.400 MHz at DR 2
12:55:38.774 → txDone
12:55:38.774 → RX on freq 923.400 MHz at DR 2
12:55:43.834 → rxTimeout
12:55:43.834 → RX on freq 923.200 MHz at DR 2
12:55:44.803 → rxTimeout
12:55:44.840 → ***** UpLinkCounter= 0 *****
12:56:15.559 → TX on freq 923.200 MHz at DR 2
12:56:15.912 → txDone
12:56:15.912 → RX on freq 923.200 MHz at DR 2
12:56:20.968 → rxTimeout
12:56:20.968 → RX on freq 923.200 MHz at DR 2
12:56:21.974 → rxTimeout

b) Gateway Live data in

As you can see the log, "A8 40 41 ~ " is my End Device’s DevEUI. Even if the Join Request packet has been received well at the gateway, there is no other further response to the request.

c) Used source code to join the network

Thank you in advance for any guidance or advice!

your rssi is most probably to high you node and gateway is on 5m apart with no brick wall

you need 5-10m with a brick wall in between rssi needs to be -65 to -80

you suffer from channel bleed

Possibly, but as the gateway is hearing the Join Request and there is no Join Accept transmission, the RSSI isn’t a factor yet.

@thera923, if you use the Learn link at the top of the page it will fill you in on the expected sequence of events. As the gateway isn’t showing a Join Accept transmission, the next step is to see if there are any errors in the console for the device. If there aren’t, then there is an issue with the EUI’s or some other setting - a screen shot of the device setup would assist.

No need to redact EUI’s, they are transmitted in plain text & included in gateway activity logs, it is just the AppKey you need to keep secret. But overall, a useful first report.

Hi, @descartes!

Really thanks for your advance! I have tried to find the cause for a few days but couldn’t. I checked your reply, so here are my gateway and device settings screenshots. I hope this will help to solve my problem.

  1. Dragino LPS8N Gateway Settings

    Gateway - Settings 2
    Gateway - Settings 3

  2. Dragino LA66 End Device Settings

    End Device - Settings 2
    End Device - Settings 3

Nice set of settings to assist, but this:

And the other thing to look at is the gateway console which will show what the Join Request has for the EUI’s - just in case there is an issue there.

Even if the AppKey is a problem we’ll be told about it. So by checking the device console we can narrow down where the issue may be.

If you’re referring to the console of TheThingsStack, I couldn’t find any error messages since the End Device is not joined to the network. The Live data also didn’t show any logs of packets coming and going. If there’s another way to check errors from the End Device’s console, please let me know.

From the gateway’s console, the detailed content of the Join request packet is as follows:

  1. Gateway live data


Thanks, @descartes.

Are there any messages at all of any kind?

The EUIs in the device config matches the Join Request EUIs, so you should see a Join Accept message, except we aren’t seeing it being scheduled as a downlink for the gateway to send.

If the AppKey was wrong, we’d see a MIC mismatch message. If the DevNonce was an issue, we’d be told.

So this is a bit of a head scratcher - let me page a couple of grown ups - @kersing & @Jeff-UK.

In the meanwhile, do you have another device you can try to sanity / smoke test with?

It looks like your problem is that the join requests are not using the required frequencies for KR920-923.

Check the allowed frequencies in regional parameters specification (table 80 on page 70)

1 Like

according to your serial monitor you are using as923 and

tx on 923.2

your gateway is set or kr920

the join freq should be

1514 The three default channels correspond to 922.1, 922.3 and 922.5 MHz / DR0 to DR5 and
1515 SHALL be implemented in every KR920-923 end-device

OK, mental note to self to continuously check frequencies.

In your first post, your LPS8N screen shot showed correct join frequencies but no, wait, it’s the redacted items that are on plan, you left the actual device un-redacted and it’s not on plan - meh. Now I have to wonder what the redacted one was about - double meh.

The LA66 source code has nothing in it that sets the region or indeed any LoRaWAN settings at all - how are they setup?

To @Piet_Pillay, @descartes and @kersing.

After listening to your advice, I checked the frequency settings of both the gateway and the End Device. The LPS8N Gateway currently has a 915MHz antenna connected and is set to the KR920 (920~923) band.

I found my mistake when verifying the frequency settings of the End Device in TheThingsStack page. As you pointed out, the LA66 serial monitor indicated that it was using the AS923 band. This was because, when I purchased the LA66 Shield, there were multiple versions available depending on the region. Since I currently reside in South Korea, the only purchase option available to me was the LA66 version for the AS923 band.

Having identified this, I changed the frequency settings of the End Device in TheThingsStack console from KR923 to the AS 920-923MHz band. I also adjusted the frequency settings of the gateway to the AS920-923MHz band.

Subsequently, I was able to verify in the Live Data of the End Device that the Join was successfully completed.

Thanks to your advice, I was able to resolve the issue.
I truly appreciate it. Thank you!!

The frequency plans weren’t magic’d out of thin air, they are legal requirements for a county. Legal as in police, courts, fines etc. There is little to no overlap between KR920 and AS923.

You could reflash the LA66 with the KR920 firmware and stay out of harms way.

And get a better antenna for the gateway to improve efficiency.

Thank you for informing me about the risks associated with using the KR920 and AS920 bands. I’ll look into how to upload the KR920 band firmware to the LA66 and give it a try.

With sincere gratitude.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.