Node-RED "Error: 14 UNAVAILABLE: Connect Failed" when using node-red-contrib-ttn


#1

Hello everyone,
I’ve installed the NodeRed application nodes with:

npm install node-red-contrib-ttn

I’ve added a ttn-uplink node, added the ttn-app but with Device ID and Field empty.
When starting the flow it fails with the notification:

13 Nov 16:36:05 - [error] [ttn app:7b65310c.73bbc] Error on connection for TTN application ttnapplicationid: Error: 14 UNAVAILABLE: Connect Failed
(node:6092) UnhandledPromiseRejectionWarning: Error: 14 UNAVAILABLE: Connect Failed
   at Object.exports.createStatusError (/home/nodered/.node-red/node_modules/grpc/src/common.js:87:15)
   at Object.onReceiveStatus (/home/nodered/.node-red/node_modules/grpc/src/client_interceptors.js:1188:28)
   at InterceptingListener._callNext (/home/nodered/.node-red/node_modules/grpc/src/client_interceptors.js:564:42)
   at InterceptingListener.onReceiveStatus (/home/nodered/.node-red/node_modules/grpc/src/client_interceptors.js:614:8)
   at callback (/home/nodered/.node-red/node_modules/grpc/src/client_interceptors.js:841:24)
(node:6092) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). (rejection id: 1)
(node:6092) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit code.

Is there something wrong with the grpc module? I am not behind a VPN like the suggested duplicate topic.


Error on connection for TTN application
Thingsnetwork node-red connection error
#2

I was about to respond that it was all working again by adding the DeviceID in my Uplink node.
But now, without making any further changes it has stopped working again.
With the same error 14, failed to connect.

Could it be that due to the whole flow working on minute and failing the other that it is related to:


(Interravikram) #3

image

Node-red ttn uplink is no more working, did not make any change on node-red. Is there any change from things network side.


(Andrew Wootton) #4

I’ve got the same problem, Node Red was connected with a TTN uplink and then stopped with the Error 14 msg. The discovery address is the default one and the TTN status is all good.


(Andrew Wootton) #5

I got it working again after a reboot (Raspberry Pi running NR). I had tried stopping and restarting NR (obviously) but to no avail, but it’s possible that I had 2 instances of the NR console running.


(Youssefbaiji) #6

i got the same problem with TTN Uplink ,is there any solution ?


#7

My solution has been to switch over to the MQTT format, haven’t had any issue since.


(La Da U) #8

Did anyone solve the issue? Have the same problem here. Also switching to mqtt-node didn’t solve the problem. Any suggestions how to solve it?

I guess the problem is regarded the disconnect when deploying the flow. After severall times pessing ‘deploy’ it stops to connect with the error described before. When I wait some hours it works again. Are the connection closed when clicking deploy?


#9

Same issue here, any solution or cause of the issue ?


#12

Please read the full topic and related topics before posting #metoo :wink:

Please consider switching over from the nodered ttn blocks (that use the discovery service) to the mqtt blocks. (I have not had a single issue since).


Nodejs error 14 connect failed
Node-RED/Grafana "No measurement specified"
(Giourtsis) #13

How did you did that?


(Eric VdB) #14

https://www.thethingsnetwork.org/docs/applications/mqtt/api.html


#15

The link that EricVdB supplied should help with that.
I think that the MQTT nodes for NodeRed are installed automatically (At least it was with my Ubuntu build)

Just drag in an [mqtt in] node, for the uplink messages set the node’s Topic to [+/devices/+/up]
In the node’s Server you click [Add new mqtt-broker…]

There you specify:
Server: eu.thethings.network
Port: 1883 (or 8883 for TLS)
On the Security Tab you set:
Username: Application ID
Password: Application Access Key


(La Da U) #16

I had to wait some hours to connect the node again after the error appeared. It seems to be a problem to deploy the nodes very often. I guess (only a guess) there is a disconnect/connect when deploying the ttn/ mqtt node.

After switching the options which node is deployed when pressing deploy (arrow on deploy button) to “modified nodes” the connection error didn’t appear again.


(Lombi) #17

I’ve setup a few days ago a LoRa Node and am using Node-Red. Everything worked perfectly finde until I received following error message in Node-Red:
“Error on connection for TTN application allora-push-button: Error: 14 UNAVAILABLE: Connect Failed”
image

I haven’t changed anything in the settings. Does anyone know what could cause the issue? I didn’t find any solution on Google yet.