Problem with Tutorial on website?


I’m trying to use that tuto but I’m confused as it speaks about selecting ABP activation mode for device. I checked everywhere but I don’t find that option in my console when creating the new device ! Do I miss something obvious ? or outdated tutorial ? but couldn’t find more recent one for the Adafruit Feather 32u4 ii !!

PS: If I posted in wrong section, please move it where it should be, not so sure where to post it !



The option to use ABP moved a bit (probably to encourage people to use OTAA as it has less issues with device restarts etc).
First you need to create a device, then go to the ‘Settings’ page of that device. On the ‘General’ tab there should be ‘activation mode’ with a selection “OTAA” / “ABP”. Set it to ABP.

Thanks for the explanation about the missing option :wink: I just try to find out now what I’m supposed to put in Device EUI as tutorial is a little too light and fast in explanations :frowning:

For ABP that value will not be used. You can use a random hex string or click on the ‘arrows’ in front of the field to switch to ‘this field will be generated’ to have TTN generate a value for you.

PS, given the age of the tutorial and the issues you are encountering you might want to consider writing an updated one for the TTN website. Future users will be grateful…

Yep thanks I figured it out and now I got sample code compiling :wink: I just have a boring issue to upload it with Arduino IDE (will have to investigate more as I was able to upload the “blink” test code without problem but unable now to upload my sketch for lora test…)

Thanks but I wom’t publish it on TTN website but on my blog ! I tried last year to publish an updated tuto for my LORA gateway I had setup but the publication system on TTN website was broken and never got any answer of TTN neither here from TTN staff so I gave up on it :frowning:

Update: I solved my problem of compilation and succeeded to upload the sketch in the Arduino/Lora board but in TTN console it still keeps as Never seen :frowning: Will have to check later how to debug that thing to know where is the problem…

That is what a lot of people do and as a result you have to search everywhere to find a working example. Please invest a little time in the community by giving back to it. If the publishing system is the issue we will get it solved somehow.

In >95% this is caused by keys/address not being used in the correct byte order.

1 Like

I understand that but TTN not following up at all with website problems is not cool at all too :frowning: I’ll check it again later if it works better now and then will be able to publish two tutorials (the one I wanted to do in past for setup of lora gateway, and this one on setup of a little node !).

I followed the tuto and filled adresses in code like that where 01 02 0A 38 came from TTN console, same for app session key and device address just inserting the 0x Is it wrong ?

// LoRaWAN NwkSKey, network session key
// This is the default Semtech key, which is used by the early prototype TTN
// network.
static const PROGMEM u1_t NWKSKEY[16] = { 0x01,0x02,0x0A,0x38,0x66,0xDA,0xD8,0x9F,0xE5,0xCC,0x32,0xE6,0xCF,0x23,0x16,0xE9};

// LoRaWAN AppSKey, application session key
// This is the default Semtech key, which is used by the early prototype TTN
// network.
static const u1_t PROGMEM APPSKEY[16] = { 0x03,0x04,0x05,0xD4,0xBF,0xB5,0xAC,0xDA,0xCA,0xB6,0x6E,0x28,0x60,0x3A,0xAA,0x20 };

// LoRaWAN end-device address (DevAddr)
static const u4_t DEVADDR = 0x12345678 ; // <-- Change this address for every node!

Update: after double checking documentation of the library used, it looks like I have filled correctly the addresses so not sure what to check now to find out the probdem !

TTN can supply the keys in msb or lsb format when copying the values, which format did you use?
And a valid address should start with 0x26…

The tuto states to use it in MSB so I did it that way (I modified the values to avoid to post real datas here but here is begin of each one), does it sound correct ?

// LoRaWAN NwkSKey, network session key
// This is the default Semtech key, which is used by the early prototype TTN
// network.
static const PROGMEM u1_t NWKSKEY[16] = { 0xE8, 0xF9, 0xDA, 0x38, 0x66, 0xDA, 0xD8, 0x9F, 0xE5, 0xCC, 0x12, 0x34, 0x56, 0x78, 0x12, 0x34 };

// LoRaWAN AppSKey, application session key
// This is the default Semtech key, which is used by the early prototype TTN
// network.
static const u1_t PROGMEM APPSKEY[16] = { 0x93, 0x45, 0x01, 0xD4, 0xBF, 0xB5, 0xAC, 0xDA, 0xCA, 0xB6, 0x6E, 0x12, 0x12, 0x12, 0x23, 0x34 };

// LoRaWAN end-device address (DevAddr)
static const u4_t DEVADDR = 0x26011A87 ; // <-- Change this address for every node!

If the keys and address are correct the question is: are you in range of a TTN connected LoRaWAN gateway? If you own a gateway you could check if it sees traffic when the node transmits.

Unhappy my own gateway is not with me and impossible to catch back for now with crisis :frowning:
According at TTN gateway maps I have few ones around (my position is that one and I have putted the LORA module outside, i’m at top of building on 4th level so I should get a pretty good range of transmission no ?
The only thing I could do would be to setup second module I have as a gateway but not sure these modules are able to do it (not much memory and processing in these) :confused:

That hugely depends on your antenna (and antenna connection).

Have you checked coverage on

That solution is no longer supported and would cause issues for other users if there are full gateways in the neighborhood.

I have done a little experiment yesterday walking through town with module on in backpack and ttnmapper linked at device on my cellphone but it never showed up !
I decided to try an other sketch specific for board I have and I have then discovered that in Arduino IDE:

BN: LoRa32u4 (433MHz)
VID: 0x239A
PID: 0x800C
SN: Envoyez un croquis pour l'obtenir

Being in Europe I guess I’m f*cked up as it’s american version no ? We are supposed to be in 868 I think :frowning:

Update: the board is labelled as Lora32u4 ii version 1.2 made by bsfrance. I added in Arduino IDE the libs for that board so I can select either the Lora32u4 that is 433Mhz or Lora32u4 ii which is indicated as 868/925 but on USB port it detects the card as Lora32u4 ii 433Mhz :neutral_face: Not sure what’s wrong there :frowning: and whatever board I select the upload fail with that error:

Error resolving FQBN: board arduino ide

Side note: new sketch I try to use and that is more recent with online activation (I modified device properties in TTN console :wink:

What chipsets are on the board? Is there a separate radio module? If so can you read the chip ids of the components on that module?

Unhappy the radio module is covered by a metal protection so no way to know what it is ! Here are photos of the board on both sides if it can help ? :slight_smile:



There not being a tick in either the 868 or the 915 box isn’t good. What length is the antenna wire? May-be that provides a clue.

Yep it’s really strange board ! here is picture of module with antenna supplied with it ! Can it give an idea of frequency of module ? There are also these little pads I’m not sure for what near the antenna connector :confused:

Without measuring the resonance frequency of that antenna it won’t tell us anything. I have seen boards with a simple length of wire connected to the U.Fl connector so I was hoping this would be the same but life isn’t that simple…
The easy solution would be to order a new module, Or even better a module with a controller with more memory as the 32u4 has limited memory available restricting usability with regards to sensors.

Yep unhappy often technology doesn’t help :frowning:

Yep I have already ordered some ESP based Lora modules that have lot more memory (I had some already but they are in an other place I can’t access for now :frowning: ) and hope to have better chances with these. When I’ll have more time I’ll continue to investigate on that module still (perhaps I should uncap the radio chip of one of these to check what is inside, it might help no ?

Thanks anyway for all help :wink: