Problems establishing a connection with CubeCell DevBoard

I just got a CubeCell Board to replace my formerly used Heltec LoRa V2 Board. I tried to use the LoRaWan example provided by CubeCell in the Arduino Boardmanager (comes in quite handy, I used lmic before but that doesn’t work with CubeCell I think).

I replaced the application information with the values that worked (and still worked, just tested it) on the Heltec Board. But I cant even get a connection with that board.

Does anyone have an idea how to debug?

Thanks in advance!

If you need any information, I am happy to provide these. Just not shure what you might want to know.

You might have a look at https://github.com/wasn-eu/CubeCell_Getting_Started/raw/master/Getting%20Started%20Guide.pdf and try the cubecell configurator to check if the board is ok.

can you give us the log output of the cubecell?
Perhabs you can try to download our configurator and flash your board with that.
you can find it all here:

@alpu thank you for mentioning my little guide.

Thank you all for your effort!

I fixed the issue. Apparently, the CubeCell Library that is used in the Arudino Examples wants to have MSB Version of TTN Keys whereas lmic prefers LSB. I just copied the codes from one project to the other and CubeCell is missing a comment on what is the correct way of noting the Keys. So by accident I send data to another application I fear (sorry to them).

By now the decive is working as intendet and I am looking forward to using it more often.