RAK831 with Raspberry Pi 3+ not connected

2022-10-22 17_56_27-Overview - HubBeLoraWan - The Things Network

I have a RAK831 module in combination with a Raspberry pi 3+ and wanted to connect it to the thing network. I followed these instructions.

Everything was executed correctly on the Raspberry. However, it is always displayed as Disconnected in the console. Does anyone here have an idea what else I can try?

Start by unmasking your EUI & ID - these are visible in the network & over the air…and will allow us to check status etc.

What do the local logs show - are you e.g. setting Reset PIN asignment correctly such that the Concentrator card starts…it does start doesnt it? :wink:

Which packet forwarder are you using? SMTC classic UDP, Jac Kersings MPPF or Basic Station or…

Note GW ID (In the console) doesnt have to be the auto generated version which is GW EUI derived - and can already see doesnt match - it can be anything yu want withing field and character limits e.g. ‘zioo-gateway-001’ etc. provided it is not an ID chosen by another user…

Also are you using an interface card e.g. the official RAK interface or say one from another source like the Hallard/ch2i versions or… or just using Dupont cables?

Those instructions are for TTN V2. We are at V3 these days. You need to use the gateway configuration file you can download from the TTN gateway page. Put that on your RPi and make sure it doesn’t attempt to overwrite it with a version from GitHub.

At first thank you for your reply. Do you mean this configuration file?

and do you know the path where I have to put this file on the RPi?

There is a file with the same name on the RPi, look for that one and replace it.

I have this 5 global_config files

I have replaced all of them with the downloaded global_confg.json but is doesn’t work. Maybe my RAK 831 had a problem. I dont know. Sorry i am a newbie in this area.

As earlier make sure config isn’t being over written….is there a local_conf? That will take precedence over global….

This is my config right now. Stored at /opt/ttn-gateway/bin/
global_conf.json (3.5 KB)
local_conf.json (3.5 KB)
And this is in the console.
I think that should be okay. I dont know why is doesnt work

When I come to save the two files for review both try to save as local_ …have you accidentaly posted same file twice (look the same & same size - might be genuinly same but…) even though calling one as global_ in your post?

Sorry my fault. This is the local file
local_conf.json (315 Bytes)

I think my RAK 831 has a problem.
I try it with another one

Make sure the reset pin is defined correctly. And make sure SPI is enabled on the RPi.

Which is where we were 4 -5 hrs+ ago :slight_smile: As you seem to be using dupont cables to connect Pi to conc card alternate is check how set in the firmware and move the wire on the Pi connector… be sure not to confuse Pi pins with GPIO with BCM pins etc…

I think I have destroyed the conc card. I unintentionally started the pi earlier even though the antenna was not connected to the conc card. Maybe the transceiver is burnt out because the conc card only has the 2 standard leds on…

Pi’s don’t use Windows paths …

Maybe, maybe not. But until you get the settings right to run the card at a hardware level, you’ll never know.

Unlikely. It would still start but just have RF issues. You need to check SPI is properly enabled and the reset pin. And if you are using DuPont wires, check each and every one of them. I’ve had too many of them that were broken. Switched to wire wrapping for reliable prototyping and real PCBs for production stuff.
And of course you need to check you did wire things correctly.

I have plenty of RPi based gateways, some with the RAK831 card, running smoothly.

You may also find you have to dial down the bus speed - though is usually only an issue where the designers inserted level shifters that then failed to support full speed… should not be an issue with direct wired, but may be worth considering if you wiring is too long or poorly done or suffering from some local interference - best as above is use a proper inteface pcb (RAK has an official one), Like Jac I have dozens of these configs (various PI’s +RAK831 -using PCB, not duponts) deployed with no major issues, it will be the details that get you!. Sadly I moved the last of my TTN Zurich/Technoblogy SMTC UDP style builds (similar to PiSupply but without direct wiring) over to alternate form and switched over PF to Jac’s MPPF last year otherwise I would follow paths, copy example file for you to follow and PM to you…

SPI is activated. I have now tried various cabling. Unfortunately without success. Do you know which pin is the reset pin on the RAK831?

Here are the logs from raspberry
logs.txt (6.3 KB)