Remote error: tls: bad certificate

Hi,

I’m trying to setup TTN Stack v3.6.0 via the getting started guide.

In the console i see this:
stack_1 | INFO Request handled duration=1.244971616s location=/console/oauth/callback?code=MF2XI.PCMSOLRBS7BTTXFCSUF4YOCBFMOFVM4BQSS3NEA.LN72OCLQT3PZME3MFF3CTMGNDXYSDYAREHHJOLXYD5TK752CNV6A&state=2o078ynjIQChSMZQ method=GET namespace=web remote_addr=192.168.1.1:59578 request_id=01E3N66R2H5D1Y17XEQDXZE93G response_size=0 status=302 url=/oauth/authorize?client_id=console&redirect_uri=%2Fconsole%2Foauth%2Fcallback&response_type=code&state=2o078ynjIQChSMZQ
stack_1 | 2020/03/17 21:25:47 http: TLS handshake error from 172.19.0.1:45398: remote error: tls: bad certificate

I’ve used a self-signed certificate. I created the root CA myself which i use on my network.
i’ve read that i should have the container trust the certificate as well, but i’ve got no clue how to do that (As i’m a docker n00b).

So, how do i configure the docker compose to accept my self-signed certificate by trusting the root CA?

The Getting Started guide intentionally does not cover self-signed certificates. You should really consider setting up your deployment in the cloud, and use the Let’s Encrypt support that is already built into The Things Stack.

Thanks for helping!

I know what you mean, and don’t disagree at all.

The problem is, i’m testing on a local network. I don’t want to host this thing so that external people can access it (which is what you need to do with letencrypt for it’s verification).
Next to that, i have a self signed CA anyway, i had my certs generated with a script that i use for all my internal services. So i would like to just re-use that.

Alternatively, i’m also happy to just disable SSL completely. I mean - it’s local and a test, i don’t need this encryption at the moment :slight_smile: