Single Channel Gateway part 3


#43

and your question is ?


(Net Bsd) #44

Why are there only 2 messages showing up?


#45
  • What is the difference between a “single-channel gateway” and a “real gateway”?

A real gateway is able to listen on 8 channels and all spreading
factors at the same time. Single-channel gateways are fixed to one
channel and spreading factor, so they will only receive about 2% of the
messages unless you specifically configure your nodes to send at the
exact same configuration as your single-channel gateway.

As LoRaWAN is a spread-spectrum radio protocol, single-channel
gateways are not LoRaWAN-compatible.
You can use a single channel gateway on the TTN network but you miss a lot of messages, if you use your own node you can match your gateway channel with that of the node and don’t miss messages because the channels are 'locked.


(Arey Tech) #46

hello all, i just install ttgo singlechannel gateway and test another node is ttggo 868 mhz node

node keep sends uplink data to gateway but how can i send downlink message to node?

for example

turn on or off message to node

thanks


(Paul B) #47

@telkamp Please excuse the completely noob question, but I am trying to use your hallard implementation, but can’t seem to find the Gateway Id. Everything seems to work fine but it just starts and stops without telling me what the id is, as per the below picture. Please could you explain where I’m going wrong?Capture
In advance, thanks a lot! Several hours of Googling don’t seem to have helped, so lets try people!


(Glbaum) #48

It would be shown in the log file, or you can work around not seeing it by starting the packet forwarder like below:

./single_chan_pkt_fwd/single_pkt_fwd

Assuming that you are in the pi folder. Also this should be obvious but sometimes people forget so before you run that command make sure you stop the service with sudo systemctl stop single_chan_pkt_fwd.


(Paul B) #49

Perfect, thanks very much @glbaum ! Just one point for anybody else with this problem in the future, running this command from the pi folder didn’t work (I assume a permission issue), but going into the single_chan_pkt_fwd folder and running ./single_chan_pkt_fwd worked perfectly.


(Glbaum) #50

I don’t necessarily remember if I needed to use sudo to run it outside of it’s folder but maybe that’s the case. I just know that I had been able to start it that way, but either way I’m glad you got it working @Paul_B!


(Jens) #51

Hello

I made a BOM at octoparts for the WeMos/LoLIN D1 mini SCGW for the PCB from @Charles and his solution at his Git .
At my BOM i made a little bit more.
Ad OLED, SMA, Conector for OLED … and so on. Describe a little bit at the end of the rows. :slight_smile:
But before i spread, can someone have a look that BOM is ok? And give me response for improovements.
If interestet you can find it here: octoBOM

Greets


(Robsonmartinazzo) #53

I used this code in my esp32 (https://github.com/things4u/ESP-1ch-Gateway-v5.0), everything is working, however I wanted to register my gateway at the gateway console, but there is a gateway key and I do not know where to put it in the code. How I do this?


(Therold) #54

I think you have to go about this the other way around. Load the sketch on your ESP and either look at the ESPs gateway dashboard / website or the serial monitor and find the “Gateway ID”. Use this ID to register your single chanel gateway with TTN. Make sure click the “I’m using the legacy packet forwarder” checkbox on the gateway registration page and the form will change to accept your gateway ID.


(William Porras) #55

I know this apply for uplink, does this apply for downlink too? Do you need to force a node to receive information in a specific downlink channel?


(Cswiger2) #56

Anything change at TTN? I doubt it as I see no news - but my Single Channel Gateway that has been happily working for a year and half suddenly stopped forwarding data around 2AM (EDT US) last night. Occasionally the gw will need a reboot but that does not help now. I have changed nothing!

Reset gateway, reset all frame counters.

It shows up as online, active a few seconds ago, but none of my devices have shown any traffic for over 12 hours now - they all (5 active devices) send a few bytes of data every 30 minutes. The gateway counter increments normally, showing 28 packages received since resetting over 3 hours ago (~5x3x2)

It is a Wemos esp8266 with https://github.com/dlarue/ESP-1ch-Gateway-v2.0 and an InAir9b module.

I’ll plug in a serial terminal when I get home.

I see on the status page https://status.thethings.network/ there was an update to a subset of server on 8/6/2018 - with only minor service interruptions expected, otherwise all normal.

It is setup to use:
$ nc -uv router.us.thethings.network 1700
Connection to router.us.thethings.network 1700 port [udp/*] succeeded!

altho in the console the router is set for ttn-router-us-west or us-west.thethings.network

Those resolve to different IPs?
router.us.thethings.network canonical name = bridge.us-west.thethings.network.
Name: bridge.us-west.thethings.network
Address: 13.66.213.36

Non-authoritative answer:
Name: us-west.thethings.network
Address: 13.66.229.235

And my application is set for ttn-handler-eu – I’ll try setting that to ttn-handler-us-west, but that states that all devices registered to this application will be lost!!

I can even see gateway traffic coming in on the console - but nothing in the application devices:
gateway_traffic


(Cswiger2) #57

Got one device back online - it’s starting to look like where the handlers could be different in gateway and applications, now they have to be the same? I created a new app with the us-west handler, and registered a new device, programmed it with the new ID and now it works. That is probably documented somewhere I should have been reading :slight_smile: