Single Channel Gateway part 3


and your question is ?

(Net Bsd) #44

Why are there only 2 messages showing up?

  • What is the difference between a “single-channel gateway” and a “real gateway”?

A real gateway is able to listen on 8 channels and all spreading
factors at the same time. Single-channel gateways are fixed to one
channel and spreading factor, so they will only receive about 2% of the
messages unless you specifically configure your nodes to send at the
exact same configuration as your single-channel gateway.

As LoRaWAN is a spread-spectrum radio protocol, single-channel
gateways are not LoRaWAN-compatible.
You can use a single channel gateway on the TTN network but you miss a lot of messages, if you use your own node you can match your gateway channel with that of the node and don’t miss messages because the channels are 'locked.

(Arey Tech) #46

hello all, i just install ttgo singlechannel gateway and test another node is ttggo 868 mhz node

node keep sends uplink data to gateway but how can i send downlink message to node?

for example

turn on or off message to node


(Paul B) #47

@telkamp Please excuse the completely noob question, but I am trying to use your hallard implementation, but can’t seem to find the Gateway Id. Everything seems to work fine but it just starts and stops without telling me what the id is, as per the below picture. Please could you explain where I’m going wrong?Capture
In advance, thanks a lot! Several hours of Googling don’t seem to have helped, so lets try people!

(Glbaum) #48

It would be shown in the log file, or you can work around not seeing it by starting the packet forwarder like below:


Assuming that you are in the pi folder. Also this should be obvious but sometimes people forget so before you run that command make sure you stop the service with sudo systemctl stop single_chan_pkt_fwd.

(Paul B) #49

Perfect, thanks very much @glbaum ! Just one point for anybody else with this problem in the future, running this command from the pi folder didn’t work (I assume a permission issue), but going into the single_chan_pkt_fwd folder and running ./single_chan_pkt_fwd worked perfectly.

(Glbaum) #50

I don’t necessarily remember if I needed to use sudo to run it outside of it’s folder but maybe that’s the case. I just know that I had been able to start it that way, but either way I’m glad you got it working @Paul_B!

(Jens) #51


I made a BOM at octoparts for the WeMos/LoLIN D1 mini SCGW for the PCB from @Charles and his solution at his Git .
At my BOM i made a little bit more.
Ad OLED, SMA, Conector for OLED … and so on. Describe a little bit at the end of the rows. :slight_smile:
But before i spread, can someone have a look that BOM is ok? And give me response for improovements.
If interestet you can find it here: octoBOM


(Robsonmartinazzo) #53

I used this code in my esp32 (, everything is working, however I wanted to register my gateway at the gateway console, but there is a gateway key and I do not know where to put it in the code. How I do this?

(Therold) #54

I think you have to go about this the other way around. Load the sketch on your ESP and either look at the ESPs gateway dashboard / website or the serial monitor and find the “Gateway ID”. Use this ID to register your single chanel gateway with TTN. Make sure click the “I’m using the legacy packet forwarder” checkbox on the gateway registration page and the form will change to accept your gateway ID.

(William Porras) #55

I know this apply for uplink, does this apply for downlink too? Do you need to force a node to receive information in a specific downlink channel?

(Cswiger2) #56

Anything change at TTN? I doubt it as I see no news - but my Single Channel Gateway that has been happily working for a year and half suddenly stopped forwarding data around 2AM (EDT US) last night. Occasionally the gw will need a reboot but that does not help now. I have changed nothing!

Reset gateway, reset all frame counters.

It shows up as online, active a few seconds ago, but none of my devices have shown any traffic for over 12 hours now - they all (5 active devices) send a few bytes of data every 30 minutes. The gateway counter increments normally, showing 28 packages received since resetting over 3 hours ago (~5x3x2)

It is a Wemos esp8266 with and an InAir9b module.

I’ll plug in a serial terminal when I get home.

I see on the status page there was an update to a subset of server on 8/6/2018 - with only minor service interruptions expected, otherwise all normal.

It is setup to use:
$ nc -uv 1700
Connection to 1700 port [udp/*] succeeded!

altho in the console the router is set for ttn-router-us-west or

Those resolve to different IPs? canonical name =

Non-authoritative answer:

And my application is set for ttn-handler-eu – I’ll try setting that to ttn-handler-us-west, but that states that all devices registered to this application will be lost!!

I can even see gateway traffic coming in on the console - but nothing in the application devices:

(Cswiger2) #57

Got one device back online - it’s starting to look like where the handlers could be different in gateway and applications, now they have to be the same? I created a new app with the us-west handler, and registered a new device, programmed it with the new ID and now it works. That is probably documented somewhere I should have been reading :slight_smile:

(Outthereandaway) #58

Hey all, I’ve built a small 1CH gateway based on a Wemos D1 mini, Ch. Hallard’s connection board (V1.3) and a RFM95. I configured things4u/ESP-1ch-Gateway-v4.0 is used to run it …
Now, on the serial monitor I am getting

Unrecognized transceiver, version: 0
Abort called

and the gateway is not connecting to ttn (nor to my wifi)

Interestingly, I had it once running when - for preliminary tests - the D1 and the Hallard board (with RFM95 and diodes D2, D3, D4 soldered on to it) were connected with wires, omitting RST and D0. After soldering everything, I can not get it up and running again. I checked all the connections several times, tried to improve the soldering joints, … still not working. Could it be any other issue than bad soldering? Has anybody experienced similar problems? If so, how was it solved? Thanks a lot for any hints!

(Sorry, I am pretty much a beginner. But I try my best…)


(Iob) #59

Have a look at the following YouTube clip from @SensorsIOT:

I built one up following it step by step and it worked jusr fine. Note the comments on which diodes to solder in and which ones not.

(Lucasgss) #60

How I put a fixed IP? I using Esp LoRa 32

(Rodri16) #61

Hi, I am using an Heltec LoRa 32 v2 Board to create a GW. SS:18, RST:14, DIO0:26, DIO1:34, DIO2:35 (working ok as node)
I have it connected to TTN but I don’t receive any message from nodes.

Using library from Kersing


Both GW and nodes are using channel 0.

From the Serial log I get:

and sometimes

loop:: readUdp calling
PKT_PULL_ACK:: size 4 From, port 1700, data: 1:93:25:4:
readUdp:: returning=4
STAT <stat update: <232> {“stat”:{“time”:“2018-10-05 14:55:17 CET”,“lati”:0.00000,“long”:0.00000,“alti”:8,“rxnb”:0,“rxok”:0,“rxfw”:0,“ackr”:0.0,“dwnb”:0,“txnb”:0,“pfrm”:“ESP32 HELTEC",“mail”:"”,“desc”:“My ESP32 Gateway HELTEC”}}
WiFi connected

What am I doing wrong?

(Arinze Izukanne) #62

To help can you provide answers to the following :

  1. Can you show the logs or serial output of the the nodes?

  2. Are you running ABP or OTAA on the nodes?


(Rodri16) #63

Hi Arizne,

I am using both ABP and also OTAA

Log from ABP, using DR_SF7

Location: INVALID Date/Time: 0/0/2000 00:00:00.00
13208 Sending… Packet queued
13367 Waiting… 968236: EV_TXCOMPLETE (includes waiting for RX windows)
Location: INVALID Date/Time: 0/0/2000 00:00:00.00
27145 Sending… Packet queued
27303 Waiting… 1839262: EV_TXCOMPLETE (includes waiting for RX windows)

log from OTAA, keep trying to join

376 Sending… Packet queued
406 Waiting… 26891: EV_JOINING

Both nodes work on a full GW, this is the metadata I get from the full gateway (ABP mode)