Skip payload encryption causes error

Good morning,

during my first steps with the v3 stack I ran into an issue while adding devices to the console (
I added a device with ABP and tried to check the option “Skip payload encryption and decryption).
This causes an error and every time I want to view this device in the console, I get an error page " An unknown error occurred. If the error persists after refreshing, please contact an administrator”.
So, I can’t even delete this device.

Does anyone know how to contact an admin?

Thanks in advance.

This sounds like an issue that was recently fixed:

If this is indeed the same issue, it should be fixed in v3.11.2 that we plan to release by the end of this week and hopefully deploy next week.

Please confirm, @adrianmares


Oh, I didn’t find this issue - It sounds really like that issue but it didn’t help.
I can’t access the “misconfigured” devices - unknown error. I tried it just a few seconds before.
I can’t delete the whole application either, because of the existing devices.

Indeed that PR should fix the issue mentioned here, once it is deployed (it is not deployed yet !).

Thanks lot Hylke and Adrian!
I will wait for the deployment and then try again.


Apart from the recommendation not to use ABP on the v3 stack, what is the use case for “Skip payload encryption and decryption”?

It was just for exploring the different functions/possibilities and moving v2 devices to v3.
I do not use ABP anymore.

The “skip payload crypto” feature can be used if you don’t want to give The Things Stack your AppSKey (application session key; used to encrypt/decrypt application layer payloads), and instead do end-to-end encryption between your end device and your application (on your own server).

This feature only makes sense in combination with an external join server, because otherwise you’d still have your security keys registered in The Things Stack. In order to use it you’d have to implement LoRaWAN crypto in your own application backend. We don’t provide documentation for that, so you’d have to read the LoRaWAN specification yourself.


I works now! I could delete the devices with the skipped payload encryption.

Thanks to all participants for solving this error!

1 Like